not reading all drams


x299 system ok I am new here I had problems after version 7.40 which showed 4 sticks of ram. using new 7,46 now only show 3 sticks. all memory working fine 4x8gbs 32gig kit in bios shows each stick and adia64 software.


  • Screenshot 2023-05-10 162004.png
    Screenshot 2023-05-10 162004.png
    272.1 KB · Views: 5
I will need to see the HWiNFO Debug File, ideally from both v 7.40 and 7.46 too.
think I was wrong very strange all other software reads all SPD 4 slots even Win 11 say 4 and in my bios I get all the SPD info correctly. Lots of other software read 3 sticks I really think it is a Win 11 bug.


  • Screenshot 2023-05-11 113606.jpg
    Screenshot 2023-05-11 113606.jpg
    661 KB · Views: 8
sorry for all the trouble just contacted corsair going to get a new memory kit something killed my spd info on 1 module. hope it was not windows 11 memory compression protection. I have the ASUS X299 Gaming E Motherboard cannot find anyway to turn SPD writes in BIOS.
Some (not well written) RGB control can overwrite SPD if it's run with other monitoring tools because they don't synchronize together.
  • Like
Reactions: PCX
so, with new kit guess I run corsair ICUE once for firmware update set all my Dimms to blue that's how I always want them then uninstall the ICUE and just use HWINFO for monitor. shall be good to go lesson learned.
Very often happen the weirdest effects when using more as 2 DIMMs and full XMP speed, but work most often fine when lower frequency or XMP totally disabled. Because often they're only made for duo, but not more. And also the chipsets can have problems then.
I had same weird problems when tried 4x8GB, but all problems were gone when 2x16GB instead.