Optimus / Hybrid Mode - HWinfo64 not detecting my integrated Intel GPU

I have a Lenovo Y740 laptop with a 9750H integrated GPU (Intel UHD Graphics 630) and an RTX 2070 Max-Q dedicated GPU. When I turn on Optimus / Hybrid Mode, my iGPU is successfully running instead of the 2070MQ. In HWinfo64, it lists my 2070 as GPU #0 when Optimus is off, and GPU #1 when Optimus is on. However, it does not show my iGPU Intel UHD Graphics 630 listed as GPU #0. I see the iGPU voltage and GPU clock speed listed under CPU, but I don't see the rest of the monitoring sensors where GPU #0 should be.

Is there anything I can do to try and get HWinfo64 to detect my iGPU Intel Graphics 630 as GPU #0. It seems to simply be missing for some reason. I'd like to be able to monitor the graphs from the sensors when I am not gaming with my dedicated RTX 2070 Max-Q.

When I had a Y740 with a 8750H and Optimus on, HWinfo64 listed my iGPU as GPU #0 and my RTX 2060 as GPU #1. However, with the 9750H the iGPU is not being detected as GPU #0 with Optimus on. Are there any settings or troubleshooting I can try to get HWinfo to list my iGPU in the monitoring list? I'm not sure exactly what to try, the settings are all pretty much stock. I've tried enabling/disabling Optimus and restarting my PC, and also restarting HWinfo64 with administrator before I restart my PC.

Please let me know if this is a known bug with the 9750H's Intel UHD Graphics 630, and what I can try to get the monitoring sensors to be detected. the iGPU is definitely in use, because I can see the iGPU watts and clock speed listed under the CPU monitoring sensors. Also, if anyone has Optimus/Hybrid Mode, please let me know if HWinfo64 detects your integrated GPU when it is turned on. Thanks a bunch!
 
This is another one with Optimus / Hybrid Mode on. I think the dedicated GPU was active in the last one. The iGPU watts and clock sensors are active under the CPU: 9750H monitoring. But the GPU #0: Intel UHD graphics is still missing. It only shows GPU #1: RTX 2070, meaning it moved the RTX 2070 from GPU #0 with Optimus off to GPU #1 with Optimus on. The integrated GPU isn't showing up for some reason though. I know when I had a 8750H, it definitely showed both GPUs listed in HWinfo. That was with a different CPU and also an earlier version of HWinfo though.
 

Attachments

Please attach two HWiNFO Debug File from both modes - with Optimus enabled and disabled. I need to analyze this issue in more detail.
See here for instructions how to create the debug files: https://www.hwinfo.com/forum/threads/read-this-before-submitting-a-report.241/
Here's the Debug file with Optimus off and only the RTX 2070 Max-Q running. Hopefully this will help. Let me know if these debug files are good, and anything I can do to troubleshoot HWinfo. Once I turned off Hybrid Mode, HWinfo showed GPU #0 as my RTX 2070 again.
 

Attachments

Martin

HWiNFO Author
Staff member
Thank you for the data, the Debug Files are OK.
Unfortunately the Optimus technology completely disables the iGPU device, so it's not visible in the system at all. The Intel GPU is not visible anywhere - not on the PCI bus, in Device Manager, nowhere.. So that causes HWiNFO to miss it because it's unable to detect its presence. The iGPU VID/Power values are read from the CPU, so this works. But the iGPU as a GPU device is not visible anywhere.
When the iGPU is disabled are there any possibilities (besides enabling Optimus) to enable it dynamically, i.e. by pinning some application to it?
 
Thank you for the data, the Debug Files are OK.
Unfortunately the Optimus technology completely disables the iGPU device, so it's not visible in the system at all. The Intel GPU is not visible anywhere - not on the PCI bus, in Device Manager, nowhere.. So that causes HWiNFO to miss it because it's unable to detect its presence. The iGPU VID/Power values are read from the CPU, so this works. But the iGPU as a GPU device is not visible anywhere.
When the iGPU is disabled are there any possibilities (besides enabling Optimus) to enable it dynamically, i.e. by pinning some application to it?
Thank you for the response and also taking the time to look into this. Do you mean Optimus disables the iGPU from being detected when Optimus is on AND off? I swear when I had the same laptop with an 8750H Hwinfo detected the iGPU as GPU0 with Optinus enabled, but maybe I incorrectly remembered or a Bios/Windows update changed things.

I do see the Intel UHD graphics in the Nvidia Control panel, under the PhysX settings it says the iGPU is connected to the laptop display. That is the only place though. If this is normal behavior though I'll not worry about it, and thanks again for your help.
 

Martin

HWiNFO Author
Staff member
I'm not 100% sure about this as there seem to be several implementations of Optimus and that might explain the different behavior you saw in the past. This might be something new, that completely disables the iGPU when it's not utilized to preserve power. And that makes sense as this is the goal of such technologies.
For such cases (when GPUs not used were disabled by technologies like Optimus), HWiNFO used special tricks to wake them up for a short while in order to detect them. But the scenario was always opposite - the DGPU was disabled when not needed and the tricks used worked (for AMD and NVIDIA GPUs). Here, the system disables the IGPU when not used and unfortunately I don't know how to wake it up from such state.
Anyway, what you observe is well OK, it's just that HWiNFO doesn't know how to detect the IGPU in such case...
 
Thanks for your help and all the info. If everything looks good in your opinion then I'll not worry about it. The iGPU is definitely working since it shows up in Nvidia control panel and it shows the iGPU watts and iGPU clock speed. I'm guessing Lenovo's version of Optimus simply doesn't allow the Intel GPU to be detected.

When I thought I saw it working, I was using the same laptop but with an 8750H and they have different Bios. My new one is a refreshed version with the 9750H and updated bios, so I'm guessing they optimized Hybrid Mode/Optimus on it to work differently, and probably keep the igpu off more. Thanks for your time and help though! The igpu watts and clock speed are the main things I wanted to monitor, so I'm good just using those. I mainly wanted to make sure Optimus was working properly on my PC and if I needed to troubleshoot or re-install HWinfo. One last question, I did install HWinfo when Optimus was off, and during reboot I have MSI afterburner waking the dGPU at the beginkng. Could this effect it detecting the igpu? And also, even with 'wake sleeping GPUs' on, my 2070 isn't being monitored when HWinfo starts until it is used, like when I run MSI afterburner. Is that normal behavior sometimes for Optimus enabled?
 

Martin

HWiNFO Author
Staff member
I'm not sure if that procedure will wake the IGPU as well, but I think it's rather unlikely.
Yes, HWiNFO wakes the DGPU up for a short while to detect it. Then the DGPU goes back to sleep, so that's why you see 0's. This is intentional behavior - HWiNFO doesn't interfere with your power savings by default. If you'd like it to monitor it, enable the "Poll Sleeping GPUs", which will cause the DGPU to periodically wake up and go back to sleep. See the embedded help in HWiNFO settings when hovering mouse over an option for more information.
 
Top