Package C6 and Core C6 residency always at 0%

excezd

Member
Configuration:

  • Ryzen 5 3600
  • Gigabyte AX370-Gaming K3 ( ITE IT8686E )
  • Windows 10 Pro 2004
Package C6 and all cores C6 residency is always at 0% - current, minimum, maximum. Tried with turning off literally every application besides HwInfo. System is idling, which can be seen with core and thread usage in the screenshot. Tried different power plans, even setting the minimum processor state to 0%. Global C-state control is turned on in BIOS.

HWiNFO64_2020-08-19_19-30-09.png
 

Zach

Well-Known Member
Hi there

First, where is the "Average" column in the screenshot of Sensor window? It could tell more...
Seems like your system does not let CPU fall into deep sleep (C6 state) at all. It could be the old chipset board (X370) or some BIOS setting you are unaware of. Do you have all CPU settings on Auto in BIOS?
I can see your CPU multi never goes under x32. It should go all the way down to x22.
Have installed the latest BIOS for the board and the latest chipset drivers form AMD directy.

I would also suggest the following
  • Global C-state Control = Enabled
  • Power Supply Idle Control = Low Current Idle
  • CPPC = Enabled
  • CPPC Preferred Cores = Enabled
  • AMD Cool'n'Quiet = Enabled
  • PPC Adjustment = PState 0
...and everything CPU realated about voltages (V/mV) and speed (MHz) on auto.
 

excezd

Member
Currently all settings are exactly as you described. Average is hidden currently, but if I enable it, it's also 0%. Also tried BIOS @ default, including RAM (no XMP), same thing.

The reason CPU never goes under x32 is because in this screenshot I'm using Ryzen Balanced, which sets a higher minimum CPU state. If I use Windows Balanced, it goes down to x22, but the C6 residencies are still 0%.

BIOS and chipset driver are at the latest version.
 

Zach

Well-Known Member
Average column make sense for a lot of readings through time. You can understand many things about the system behavior.
I hope chipset drivers are from AMD and not from Gigabyte...

If you want my opinion, AMD Ryzen Power plans (all of them) and plain windows Power plans are unoptimized for ZEN2. I use for many months now the 1usmus Universal Power Plan for Ryzen and I believe is the best.
Here are some very interesting reads and I suggest you give them a go. You will get to know your CPU a bit better.


Here are some examples of my system (R5 3600, GB X570 Aorus Pro) for 2~3 hours duration on idle and low work loads as browsing, watching videos and movies.

1. AMD Ryzen Balanced PowerPlan (CPU min 5%, max 100%)
Untitled08.png
Look the red boxes and more...

2. 1usmus Universal Power plan (CPU min 5%, max 100%)
Untitled07.png

3. 1usmus Universal Power plan (CPU min 5%, max 98%)
Untitled06.png

The difference between 2 and 3 is max CPU state. In 3 you will notice that CPU multi never goes beyond x35. thats because the workloads are very low. If needed it with hit x42 on certain cores, the best ones.
The difference between 1usmus power plan and all the others is that the windows scheduler sees and recognizes the cores better and loads them accordingly. Not all cores on a ZEN2 CPU are created equal (see the core clock perf# numbers)
You can see that on 2/3 on the average effective core clock of each core. This reflects directly on all C-state (C0,C1,C6) residencies (average column) of each core.
On 1usmus's plan the loading and C-states are related to core perf# order and if the cores are on the same CCX.
On AMD or Win plans the loading is totally random...

I understand that all this is out of the scope of this thread initially, but I found the oportunity to explain some things, if they are not known to you.
 

excezd

Member
I fiddled with the power plans quite a bit, and while the CPU clock does decrease - to 2.2 GHz exactly as yours, the C6 residency never does. That always stays the same, no matter the power plan and no matter the BIOS setting. I would just love some confirmation if this is a HwInfo bug regarding some motherboard/chipset/Ryzen combination, or if my CPU is somehow flat out refusing to enter C6.

Attaching the screenshots of average column turned on, both Ryzen Balanced and Windows Balanced, no difference except for minimum clock (about 10 minutes idling):
 

Attachments

Zach

Well-Known Member
There are more differences than minimum clock between them. Max clock also different and average voltage, but voltage is directly related to speeds.

I strongly suggest to try 1usmus Universal Power plan v1.1 and see the behavior. It could change a lot. It’s not certain though.
Your situation could be due to the old chipset that was not meant to be for ZEN2. Yes it is compatible, but may cannot cope with all the ZEN2 features and advanced management that this complex chip requires. ZEN2 is way more advanced chip than ZEN/ZEN+.
I can see you are also not hitting the max clock of the R5 3600 which is 4.2GHz, on some cores at least.
 
Last edited:

excezd

Member
This is because it's a screenshot from ~10 minutes of idling. It hits 4.20 on two cores under light load and around 4.0 GHz under full-core load. Tried 1usmus as well, no difference in C6.
 

Dalai

Well-Known Member
Is it possible that the resolution of the system timer was somehow changed? It certainly has an influence on core voltages and power consumption, so I can imagine that it's also able to prevent the cores to enter C6 state.

Anyway, use a tool like SysInternals ClockRes (CMD only) or Timer Resolution (GUI) to find it out. A normal system timer interval is 15.6 milliseconds. If it's 1 millisecond on your system, and it stays that way even when closing all programs (especially web browsers), you have a problem.

A little background story:
When I switched to the AM4 platform I was wondering why the system wasn't putting the cores to the lowest possible voltage on idle and also why the system had a higher power consumption compared to a fresh Windows installation. It cost me a couple of days to find the cause. Eventually I found that it was an old version of USB Safely Remove, and once I updated that, the power consumption was back to normal, and the core voltages also came back down on idle.

Regards
Dalai
 

excezd

Member
It says minimum 15.625 and maximum 0.500. Screenshot attached. Will check the USB Safely Remove thing.

Edit: I don't even see "USB Safely Remove" anywhere on my PC. Is that a default Windows thing or additional? If it's additional I've never even installed it.
 

Attachments

Dalai

Well-Known Member
A current resolution of 15.6 milliseconds is normal. OK, it was just a thought, based on what happened to me.

PS: USB Safely Remove is a third-party application (and service) that provides much more information and features than the regular Windows Safely Remove Hardware function.

Regards
Dalai
 

excezd

Member
I'm inclined to believe that this is some sort of weird HwInfo bug because Ryzen Master does show the cores as sleeping. If anyone else has any other ideas, I'm willing to try.
 

Zach

Well-Known Member
Sleeping state is also the C1...
I believe I already said that but here:

C0 = active state
C1 = sleeping state
C6 = deep sleeping state

So, C6 is the advanced sleeping state. Practically turn-off cores.
Are you sure that X370 or the particular board can give that to this CPU?
I'm just speculating here. Cant be sure. Have you try to find other users with your combination of hardware or close to it at least?
 
Top