ASUS Prime X470-Pro - Fan headers shutting down after a while when running HWiNFO

Ennea

New Member
This probably sounds crazy as hell, and HWiNFO may not be even be the culprit here, but please hear me out first.

End of April I built a new PC around the Ryzen 7 2700X, and everything was fine (and still is, mostly). On the first weekend, after playing some games for a while, I noticed temps were getting a bit hot. Shortly after, I realized all the case fans had shut down. The following day (probably Sunday or so) and the following weekends, it also happened. Always after I had the PC running for at least around 8 hours, sometimes after longer times, all the case fans would shut down.

Overall, this seriously weirded me out and made zero sense. Weird sensor readings (37000 RPM on some case fans, or stuck case fan readings) didn't help the situation either. ASUS support suggested a potential power issue, and asked me to test a more minimal setup (fewer fans, only one RAM module), but that didn't help either. I then also tried fiddling with fan tuning in ASUS BIOS. First I modified the curves to something else, then I set the fans to full power. Neither helped. I then googled again (last weekend or so) like I have before, but this time I found this reddit post: https://www.reddit.com/r/Amd/comments/8iykdf/the_asus_prime_x470_pro_has_been_nothing_more/

A fellow user with the same problems I had! They claim the problem is ASUS' implementation of PBO doing something it shouldn't or some such. I hadn't even realized it's turned on, so I looked for the setting in the BIOS and set it to "Disabled" from "Auto". But again, it didn't help. I then found the post in the same reddit thread I didn't want to find: https://www.reddit.com/r/Amd/comments/8iykdf/the_asus_prime_x470_pro_has_been_nothing_more/dyxb31b/

Somebody claiming to have had the same problem, and it stopped once they uninstalled HWiNFO. And that's why I'm here. After disabling PBO didn't help, the first thing I did was disable monitoring for any sensor in HWiNFO I didn't need. This left me with the sensors for CPU usage and temperature, GPU usage and temperature and fan speed sensors. But again, same problem. I then tried once more with the fan speed sensors disabled as well. But again, after 8 hours, my fans turned off... so today, for the first time, I didn't have HWiNFO running at all. So far, my PC has been running for about 13 hours with no issues. And so, it really does seem like HWiNFO is the culprit. But why? I'd really like to have it running again, for monitoring temperatures and such...

Tomorrow's a holiday here in Germany, so I'll have enough free time to run the PC long enough for the problem to occur again. I will generate a report and debug file for this report tomorrow. Until then, maybe somebody has an idea what may be causing this.
 

Martin

HWiNFO Author
Staff member
No, that doesn't sound crazy at all ;)
Some ASUS X370/X470 boards are known to have problems when other monitoring applications access their sensors, which can use the symptoms you describe (invalid readouts, malfunction of the SIO).
Initially these issues were quite heavy, but we found a solution with ASUS that significantly reduces the probability of occurring, so on some systems this should not be happening. But still there's a small chance, especially when running for prolonged time.
ASUS continued investigation and developed an alternate solution that should completely fix this problem. We spent a lot of time with them working on this, I was directly involved in this process. We came with a solution, which however wasn't yet released by ASUS as part of an official BIOS. So HWiNFO has support for this already, but you will need to wait for ASUS to release the fixed BIOS.
For the time being, you might try to run HWiNFO, but with the ITE sensor (and most probably the ASUS EC sensor too) disabled - you will need to disable monitoring of the entire sensor (it's heading included). This should workaround the problem, but you won't be able to see any values from the mainboard sensor.
 

Ennea

New Member
Man, it's such a relief to read that. Seriously! I disabled monitoring of the ITE sensor. I don't have an EC sensor, however. Should I see that anywhere, or do some boards not have one?
 

Martin

HWiNFO Author
Staff member
If you're not running the latest Beta version (v5.83) then the EC sensor won't be shown.
 

Ennea

New Member
Does that mean I don't have to worry about that sensor, then, or should I get the beta so I can disable monitoring for it?
 

Martin

HWiNFO Author
Staff member
You don't need to worry about it as the version you're using doesn't access that sensor at all.
 

Ennea

New Member
Alright, sweet! Thanks for all the info, and especially the quick responses :) I'll keep watching out for BIOS updates that may address this.
 

CanoeBeyond

Member
I'm having this problem on an ASUS Prime X470-Pro MB.  ALL the fans stop and temps skyrocket.  Latest BIOS.  Any idea when this might be fixed?
 

CanoeBeyond

Member
Any information on whether this ASUS "fans stopping" problem has been solved?  Would be good to know while I can still return this ASUS MB as it's a fatal bug.  In talking to other ASUS MB users it seems that this is a common problem with many if not all ASUS motherboard models.  I've never seen it on MSI, Gigabyte, ASRock, or Foxconn.  Thanks.
 

CanoeBeyond

Member
Thanks for the update Martin.  Guess I'll have to return this ASUS MB for an MSI.  They've been bulletproof on my Ryzen builds.  It hard to believe that ASUS would let such a killer bug go unfixed, but to be honest my experience with ASUS in the past has not been positive.
 

CanoeBeyond

Member
Martin, has this [font=Verdana, Arial, Helvetica, sans-serif]SIO (ITE) chip problem been solved with v6.04 or via ASUS?  It's hard to test because the problem is so erratic.[/font]
 

Martin

HWiNFO Author
Staff member
I'm afraid you'll need to test if ASUS fixed that. In HWiNFO there's nothing else I can do here.
 

CanoeBeyond

Member
Martin said:
I'm afraid you'll need to test if ASUS fixed that. In HWiNFO there's nothing else I can do here.
Thanks for the quick reply Martin.  It's difficult to test as it will be fine for weeks and then all of a sudden the fans stop.  Thankfully TThrottle saves the machine.  I was too lazy/busy to return the ASUS MB so tried uninstalling the ASUS utilities which are useless anyway and disabled MB monitoring in HWiNFO.  Haven't had a negative occurrence since.  Wondered though if it had been fixed.  Tried dealing with ASUS and they're absolutely useless.  Thanks much for working on this problem and thanks for the great HWiNFO utility.
 

Martin

HWiNFO Author
Staff member
I'm sorry that I cannot give you more precise information, but ASUS is currently very busy with new platforms and they cannot spend on this issue as much time as in the past. So I don't have the latest info about this status.
 

A.M.

Member
Martin
Thank you for efforts to solve the issue, do you have some fresh info on the issue besides recent user reports on the forum?
 

KnightAzul

New Member
Hi,

I had exactly the same issue last night. I was stress testing a new build with a Prime95 blend stress test running overnight, and monitoring with the latest stable Hwinfo (version 6.14). No other monitoring applications were running. In the morning all the fans: the CPU and 2 x chassis fans were all physically shutdown and Hwinfo reporting 0 rpm for all. According to Hwinfo the max CPU temperature had hit 98 degrees at some point overnight, and the CPU was currently at 95 degrees with the Prime95 test still running with no errors reported. I have no idea how long it had been running at 95 degrees.

95 degrees is the max allowed temperature of my Ryzen 3600 according to AMD specs. I suspect the CPU had reached thermal throttling, although Hwinfo did not indicate that this had happened. I was surprised with all the fans shutdown and those temperatures that the Prime95 test still running with no errors reported! I would have expected the system to shutdown or at the very least get some errors.

I have a Asus Prime x470-Pro mother board with the latest BIOS 5220. In the BIOS I have Q-Fan control set to be disabled for all fans so that they run at max speed all the time.

I read in the posts above that this could be an issue to do with Hwinfo polling the motherboard sensors and that a workaround could be to run Hwinfo with the ITE sensor disabled and EC sensor disabled too.

Some questions:
  • I don't have ITE sensor listed in the Hwinfo sensors windows, but there is ASUS WMI. Is ASUS WMI the one that I need to disable?
  • The EC sensor disabling is done under settings (Safety -> EC support)?
  • Does this issue only happen when the CPU is under load, or is it simply related to the length of time (hours/days) that Hwinfo polling the motherboard sensors?
  • I assume that "normal" programs such as Windows Task Manager monitoring CPU would never have the same effect?
And finally, could I possibly have done any damage to my new Ryzen 3600 CPU with the temperatures being so high over a possibly long period of time (hours)? Or would the Ryzen thermal thottling have protected the chip?

Thanks!
KnightAzul
 
Last edited:

Martin

HWiNFO Author
Staff member
If the ASUS WMI sensor is shown, then HWiNFO is using the alternate method to access the SIO/EC that was developed to workaround the problem you just experienced. In this mode HWiNFO doesn't access the SIO/EC directly. So if you experience this issue also with the ASUS WMI sensor, then the problem is in ASUS BIOS. You should upgrade to the latest version to see if that fixes it. If not, it should be reported to ASUS.
Appearance of this problem is not related to system load, it can happen completely random and the probability cannot be determined.
 

KnightAzul

New Member
Many thanks for your quick answer!

I do have the latest BIOS 5220 installed for the Asus Prime x470-Pro.

The issue happened when Hwinfo was monitoring with ASUS WMI enabled (by default) and EC sensor enabled (by default under settings). I never saw ITE sensor listed in Hwinfo.
I'll contact ASUS with this information.

Also will keep Hwinfo monitoring with ASUS WMI and EC sensor disabled. This should work around the issue? All I want to see really is the CPU temperature (current, min and max).

Thanks,
KnightAzul
 
Top