Deadlock (freeze) system when opening the Sensors section


Hey. When I open Sensors, the system stops responding. Only reboot helps. In addition, I use the Rainmeter with a skin, which receives information about the HWinfo sensors through the shared memory. So the plugin cannot connect to HWinfo.
It all started after installing a clean system. Attached are the report and screenshots



Please attach Debug File of the crash. If the system stops responding, you'll need to reboot and then grab the file it produced during the previous session.
This seems to be due to a problem with configuration of the PCH Thermal Device. Check the BIOS if it contains some options for this or try to upgrade it.
Could there be a problem with the hardware drivers?
History. I had a system. I recently bought a new motherboard, processor and memory. Collected a new system without reinstalling the operating system. That is, I just connected the ssd disk with the old system and everything worked. HWinfo also continued to work correctly in conjunction with Rainmeter. A few days ago, I reinstalled a clean system on the same disk. After that, problems began.
That's also possible, but I'm not sure what exactly might be causing this. Virtualization might be such reason, but that doesn't seem to be active.
Virtualization is up and running.
Maybe there are at least suggestions in which direction I should continue my investigation?
Try first to disable Virtualization to see if that might be causing it. If that won't help, I'd suggest to look into BIOS settings.
By the way, the previous processor did not fully support virtualization.
There are a lot of settings in the BIOS. I'll try to figure it out.
If there is a result, I will let you know.
Thank you!
The problem was solved after installing all the Windows updates and reinstalling the chipset drivers. I don't know what exactly helped. Thank you for your answers and your wonderful software product HWinfo!