Freeze @ Detecting Video Adapter(s)...

Irody

New Member
Hey, after I updated my GPU driver and cleared my CMOS I'm not able to start HWinfo anymore :p
If I disable SLI in the Nvidia Control Panel I can start HWinfo without any problems. When HWinfo is running I can re-enable SLI and it shows me the correct data. When I restart HWinfo the same problem appears - even after System restart.

Any advice would be great :)
Will attach my debug file.
 

Attachments

Martin

HWiNFO Author
Staff member
It seems the problem is inside NVIDIA's drivers, more precisely the NVML library. I think the driver update has broken something there.
I'm sorry, but this needs to be fixed by NVIDIA.
 

rauf

Member
Thanks for clarifying, had same issue since 368 series. Latest bug free was 365.19 at least for me.
Workaround - kill HWinfo proces, turn off sli, start HWinfo, turn on SLI
 

rauf

Member
btw it occurs only when im on 4th monitor pluged to the second card (SLI setup), when im in surround or any single monitor plugged into first card HWinfo start without problem
 

Irody

New Member
I think NVIDIA fixed it. At least it is working for me after I updated the GPU driver yesterday to 368.81. Running HWiNFO64 5.32-2900. I have 970SLI and three monitors connected to the card on the bottom. (not sure which one is the parent and which is the slave :p)
 

rauf

Member
Drivers 368.81 bug is still there.

Always when cards are in shown position, HWinfo can't start. Turning off SLI solve it.



Tried untick 'Reorder GPUs' in HW Settings no luck.
 

Martin

HWiNFO Author
Staff member
The problem seems to be in the very beginning of NVML (NVIDIA's own library), when trying to initialize it.
I have added a workaround so you can use HWiNFO until NVIDIA fixes this.
Please get this build: www.hwinfo.com/beta/hw64_533_2911.zip
The new option to disable NVML is not visible in settings, so before starting the new build you'll need to open the HWiNFO64.INI file using a text editor (i.e. Notepad) and at the end of the file (under [Settings] section) put the following line:
NvmlSupport=0

Please let me know if that helped.
 

rauf

Member
Unfortunately that doesn't help.
After restart when SLI is enabled, HW process just stay behind the door and tries to start ;)



I have to kill it, disable SLI, start HW again then enable SLI. Thats the only way.

Let me know should I check any other option, or test it without other apps?
As for now im with:
-MSI AF
-RTSS
-Razer Synapse
-Manager HD Audio (Asus mobo) ROG SupremeFX


Thanks for help
 

Martin

HWiNFO Author
Staff member
Thanks for the feedback.
Please attach a HWiNFO Debug File created using the new build. If it hangs, please kill it and then grab the DBG file.
Also please attach the HWiNFO64.INI that you used - I want to make sure the new option was added correctly.
 

rauf

Member
logs attached

After full circle (SLI off, restart HW, SLI ON) parameter

Code:
NvmlSupport=0
switch automatically to value=1

So i've double check it before testing.
 

Attachments

rauf

Member
Now we are talking ;)
OK, let you know how stable it is after 1-2 days. Ar first looks like problem solved.   :heart:
 

Martin

HWiNFO Author
Staff member
Thanks for the testing, glad to hear that it works even though the problem is on the NVIDIA side :)
 

rauf

Member
Sure ;) Is this known problem for NV, should we raport it on geforce forum?

And btw that NvmlSupport relate to my mobo or uefi in any way?
 

Martin

HWiNFO Author
Staff member
I don't know if NVIDIA is aware of it, I haven't reported it.
Perhaps it would be good if uses would report the problem, you can best describe your settings which affect it. The problem happens in the nvmlInit() function - it hangs with your configuration.
 
Top