Hotkey handling for RTSS OSD display toggle is quite bugged (HWiNFO64)


New Member
As the title says: the most serious issue I had with it was when setting the hotkey to Num-0. It works in-game as a toggle, as you'd expect, however it seems to disable the key otherwise. That is, I hit the key in whatever text field in Windows, and it's like the key is dead. Doesn't make a '0'.
I took my keyboard apart yesterday because I thought it was a hardware issue(!).  :-/
Now I can't help but chuckle a little when I've just realized that it's a bug with HWiNFO (I used to use MSI Afterburner with this same install of RTSS, and this didn't happen, so it's probably not an RTSS issue per se).
Hey, at least the keyboard isn't broken, and it did need a cleaning anyway.  :D
Changing the hotkey to CTRL+Num-0 works in-game to toggle the OSD, AND more importantly, it works out-of-game as it's supposed to Edit2: Actually, it steals that hotkey combo also so that you can't use it anywhere else.
Another issue with the hotkeys is that using CTRL+ALT-(Any Key) doesn't seem to work. It'll allow you to set it, but it won't toggle the display.
I tried to use my old hotkey of CTRL+ALT+Num-* initially, it didn't work, and I forgot about it until the other day when I tried a different key combination (Num 0), which did work. Forgot about it until yesterday I realize hitting Num-0 wasn't outputting anything while typing, and thus my keyboard vivisection.
FWIW, running Win7 x64, latest non-beta of HWiNFO, latest RTSS. Let me know if you need any more info from me.
Hope you can sort it out, and thanks for the great app! The RTSS integration is excellent otherwise. Really like the labeling and organizational abilities.
Edit1: Not to be nit-picky, but I thought I'd mention it as it *may* be related, and is at least on the same topic: response of RTSS to the hotkey is... sluggish at best, and seems to vary in response time depending on what hotkey combo is set (though that last part may be coincidence or something). Takes a second or two, typically, before the display toggles on and off after I've hit the key (combo).
The hotkey defined is a system-wide one, it's not possible to define a hot key that would work in a certain application only.
From your description I'm not sure about the other problem. Does it mean if you set it to "CTRL+Num-0" that the sole pressing of "Num-0" (without Ctrl) doesn't work in other applications? I have tested this and I don't see such issues.
The reaction to the hotkey pressing depends on the refresh interval defined in HWiNFO/sensors, which is 2 seconds by default, but can be changed.
Martin said:
The hotkey defined is a system-wide one, it's not possible to define a hot key that would work in a certain application only.
Sorry, maybe I was a bit too verbose and made things confusing.
It seems that any alpha-numeric key that is assigned as a hotkey will cause that key to not register a keypress outside of apps/games that are using RTSS.
Example: Assign 'A' or 'CTRL+A' as the hotkey, and your 'A' key will stop working. HWiNFO hooks the key or something, and it's no longer usable by anything other than HWiNFO. It's as if the key on your keyboard stops working, hence my thinking it was a hardware issue with my keyboard.
Furthermore, a hotkey combination containing 'CTRL+ALT+(Any alpha-numeric key) simply doesn't work. It doesn't toggle HWiNFO's RTSS info, AND it has the above effect of rendering that alpha-numeric key effectively 'dead'.
Does that make sense? Thanks for the quick reply. Also thanks for answering the question about the refresh interval, that helps.

Please let me know if I can provide any other info.
Thanks for the clarification. Unfortunately I could not reproduce the problem when you for example assign "Ctrl-A" and the entire "A" key stops working. If "Ctrl-A" stops working in other applications it's OK, since this combination is reserved for the whole system (not just the application where you use RTSS).
Which operating system do you use?
Can you try to assign that key (Ctrl-A), click OK button and then go back into the settings if you see the "Ctrl-A" assigned ?