HWInfo sensors crashes/closes itseft after 5-10minutes

GreyGoose

Member
Hello,

I've been using HWInfo for years and I've never had any issues
until I reinstalled a fresh Version of Windows 10 PRO a few days ago.

HWInfo sensors (I usually don't use summary at all) seems to run fine at first,
but after around 5-10minutes it just randomly shuts off without any error message.

What I've tried to far:
-Reinstall HWInfo
-I changed all the settings in the safety tab to the opposite of the default
value, so all checked boxes to unchecked and the other way around.
-Monitor nothing but one drive (that I usually don't monitor at all)
-Run no other programs but HWInfo sensors

--->Still crashes after 5-10min

The only thing that stopped it from crashing, was to only run the summary without the sensors.

Specs:
CPU/MB/RAM: 4690k | ASUS Z97 A | 2x4GB Ram
GPU: GTX 1080Ti
SSD: Samsung 970 Evo 1TB (M.2 NVMe)
Screens: 3840x2160 + 2560x1080
OS: Windows 10 PRO

Let me know, if you need any more info.

Thanks in advance for any help ;)
 

Martin

HWiNFO Author
Staff member
Hmm, this is a strange problem..
First, please try the latest Beta version. In case you use a custom order of sensor values, try to also a "Restore Original Order" from sensor settings / layout.
If the problem persists, please enable Debug Mode (as described here: https://www.hwinfo.com/forum/Thread-IMPORTANT-Read-this-before-submitting-a-report) and after it crashes, please attach the HWiNFO64.DBG file it created. The file will be probably quite large, so you might need to compress it using 7zip, RAR, ZIP, etc..
 

Martin

HWiNFO Author
Staff member
Thanks for the data. Please try to do a complete "Reset Preferences" from main settings of HWiNFO and let me know if that helped perhaps.
 

GreyGoose

Member
Thanks, seems to work now.

I will make small changes over the next few days until hwinfo looks like before I reset everything.
If it starts making problems again, I'll tell you and send the .dbg.
 

GreyGoose

Member
Alright, found it. Took me a bit, but I got there.
Changing the Multi of "Memory Clock" from 1 to 2 will result in crashes 5-15min after launching HWiNFO.

All my other settings (.reg file), Screenshot and .DBG file can be found here:
https://drive.google.com/open?id=1IPts8WlfnUKLPfoK297UhCIbxEQbIITz

If anything is unclear or you need other infos let me know.

edit:
Memory Clock also was not monitored while setting it to 2, not sure if that matters.
 

Martin

HWiNFO Author
Staff member
I have tried to reproduce this problem according to your information and settings, but I can't - it won't crash.
Also it would be extremely unlikely that such multiplier might be causing a crash.
Can you please check again if the crash is really caused by the memory clock multiplier or perhaps something else?
 

GreyGoose

Member
I'm 100% certain tho.
It's stable with the settings at default (1), even after running for 5hours+, no issues.
And out of the at least 5 times I tested with the multi set to 2 it crashed every single time.
 

Martin

HWiNFO Author
Staff member
I saw in the files you provided that you use several other settings - disabled items, alarms, RTSS, etc.
Can you please try to start from clean (Reset Preferences) and then only change the memory multi to x2 if it will crash ?
 

GreyGoose

Member
"Reset Preferences" now seems to do nothing... (the Option right over "Backup User Settings" in the "General" Tab).
E.g. "Auto Start" and "Show Sensors on Startup" are still checked and all the disabled items are still disabled, VRAM Multi is still 4 and so on.
Just rebooted my PC and pressed the Button a few more time, restarted the problem, still no results...

I created a new folder with todays date in the google drive folder that I shared with you.
In it you'll find my current .ini and and a new .reg I just created.
Hope that helps
 

Martin

HWiNFO Author
Staff member
I can see that those settings weren't reset properly. Also note that "Reset Preferences" does change only user-specific settings, not those on the page where the button is located. That might be confusing, I admit.
Please try the following:
1. Right after starting HWiNFO when the initial welcome dialog shows, click Settings and then "Reset Preferences"
2. Close HWiNFO
3. Start HWiNFO again and verify that your custom sensor settings are reset to defaults
4. Change the memory clock multiplier and see if the crash will happen again
 

GreyGoose

Member
Damn, it's now running for a little over 22minutes and still no crash.

edit: (I followed the steps and was able to reset the preferences)
edit 2: It's 100% stable, no crash after hours
 
Top