HWiNFO64 freezes when launched in sensors only mode and possibly causes bsod


New Member
I am trying to solve an issue with my PC and I discovered that HWinfo seems to make it crash when opened in 'sensors only' mode. It freezes on the 'analyzing devices' part and no matter what I do in task manager, I can't kill the process. Leaving it alone doesn't cause any immediate problems; it just remains indefinitely hung. The problem is when I try to shutdown, restart, sleep or hibernate while the program is frozen. Then the whole system freezes and eventually crashes. Strangely, I never actually see the blue screen, but the error shows in the event log as follows:

The computer has rebooted from a bugcheck.  The bugcheck was: 0x0000009f (0x0000000000000004, 0x000000000000012c, 0xffffe002076f2040, 0xffffd0002e02b8b0). A dump was saved in: C:\WINDOWS\MEMORY.DMP. Report Id: 011016-10437-01.
So far, I can reproduce the issue, but I'm not sure if this is a bug in HWinfo or if my computer is just being a pain.
Windows 10 pro, 64-bit
i7 6700k (not overclocked...yet)
Asus Maximus VIII Ranger
16gb DDR4 @ 2400mhz using XMP
Nvidia gtx 960
Unfortunately, I couldn't get the debug file (well I did, but it was 0 bytes in size).
Sometimes after such a crash the DBG file can show 0 bytes length, but in fact if you try to open it, it will contain data and adjust its length properly.
As first I'd suggest to try to disable Drive Scan to see if that can fix it. Let me know the results...
Still crashed. I have the debug file from last night and today attached.

Edit: Also, apparently this happens when I run it without the sensors only option... Now I'm confused because that didn't happen yesterday


  • HWiNFO64.DBG
    3.3 KB · Views: 3
  • HWiNFO64_2.DBG
    3.3 KB · Views: 1
Hm, the last reported crash seems to be something different than the originally reported BSOD. This is seems to be very similar to: http://www.hwinfo.com/forum/Thread-DeadLock-while-Analyzing-Devices-Win-10
which is a problem of the Windows 10 system. You should be able to reproduce it by going into Device Manager, selecting the "Intel(R) 100 Series/C230 Chipset Family SATA AHCI Controller" under "IDE ATA/ATAPI controllers", then right-click Properties, choose the "Details" tab and try to list properties (especially Address or Device instance path). If Device Manager faces the same issue as HWiNFO, then it proves it's a fault of the operating system. I'm afraid, Windows 10 still seems to have a lot of bugs that need to be fixed.
Yeah, that triggered it too. I wonder if this is related to Intel's storage drivers, because I had a similar crash on my Win 10 laptop a few months ago (blue screened when put to sleep with the same error as above). That crash was caused by iaStorA.sys, which is also on this computer.

I'm liking Windows 10 less and less.
The first problem (BSOD) was probably because of storage drivers. I'm getting an increasing amount of such reports, most of them caused by Intel RST or ASMedia drivers. Some Intel RST drivers seems to work better, also it seems that later ASMedia drivers don't cause BSODs anymore, but on some systems the drive might disappear.
The other issue is definitively a Windows 10 problem.