Introducing : Remote Sensor Monitor - A RESTful Web Server


New Member
I'm having trouble using the program on an Asus laptop.
I thought it was a problem for my Asus laptop, but I had the chance to try it on another Asus laptop, but it did not succeed.
The program does not make any mistakes, but as soon as I try to see the page nothing is displayed.
I'm saying that on Asus I'm using Windows 10 (both in Home and Pro version) and it does not work, while on other PCs (both fixed and portable and with Home and Pro versions) it works smoothly.
In a nutshell, Asus does not work, even though it does not show any problems.
How can I fix it?
Thanks in advance to who will respond.


  • rsm_error.PNG
    19.2 KB · Views: 33


HWiNFO Author
Staff member
According to the screenshot it looks like HWiNFO is not running. The only tool that was found is OpenHardwareMonitor.


New Member
Martin said:
According to the screenshot it looks like HWiNFO is not running. The only tool that was found is OpenHardwareMonitor.

Here is a screenshot with open HWiNFO.
I also opened the IP of the page both on Chrome and Firefox to see the problem.


  • rsm_error2.PNG
    210.1 KB · Views: 41


Michael Z Freeman said:
Looks useful :) I can probably pull info from the json using CLI in Linux. But does anyone know of a Linux tool/app to display the info graphically ?

Delayed response I know, but I would love to get more information into a backend and visualization tool I've been packaging. I've tried using collectd's JSON plugin but I'm not quite skilled enough in this area to adapt it to the formatting output by the Remote Sensor Monitor web server.
The tool I've been packaging is based on Grafana (visualization), Graphite (database) and collector (data collector). You can find it on its github page here:
I'm pulling a bit of info right now with OpenHardwareMonitor but its with a separate, slower script so I have not packaged that into gamergraf.


OHM has a fraction of the data that HWiNFO64 has. There isn't much worth charting that Afterburner doesn't provide, and there is a lot that Afterburner does provide. Would rather collect Afterburner (for FPS and other things) + HWiNFO64 for most of the rest of the stuff.


New Member
Hello, I keep experiencing HTTP 500 error after running RSM for ~1 day or more. Server stays running but does not log anything of relevance. GET <server-ip>:<port> returns only HTTP 500 with no output to stdout or stderr.

When GET / returns HTTP 500 I still can access /config normally and enable/disable sensors there. For my setup I only use the HWiNFO source. Restarting RSM fixes the issue.


New Member
Hi, how to remove "Remote Sensor Monitor.sys" injected into process 'System' and why isn't it unloaded when the program exits?


HWiNFO Author
Staff member
PaulBags said:
Hi, how to remove "Remote Sensor Monitor.sys" injected into process 'System' and why isn't it unloaded when the program exits?

"Remote Sensor Monitor.sys" is not part of this package and anything else related to HWiNFO. So you will need to check elsewhere.


New Member
This sounds like a great addition to HWiNFO. The issue I'm coming across is that after the web server starts, as soon as I close the command prompt window, the web server apparently closes with it. Is this by design? How do I keep the web server running without having to have that window open (and of course, minimizing it isn't the solution  :p )?


New Member
Stopped working after WHiNFO 5.70-3300 released

I've been using RSM for years and now, after updating to latest stable version (5.70-3300), it doesn't work any more.
I believe something is wrong with the shared memory access.
Error message: "Please wait for the web server to start..An error occured while opening the HWiNFO shared memory! - Unable to find the specified file."

See attached.

Any ideas?

btw, outstanding product and the easiest way (by far) to report metrics like PC temperature to Nagios!


HWiNFO Author
Staff member
There was no change in HWiNFO regarding shared memory in the latest version. So I believe the problem must be in the RSM somewhere.


New Member
Correction: It works fine now!
It seems that I now need to start HWiNFO in "sensor only" mode for the RSM to work.
In default full mode it throws this shared memory issue for some reason...

I don't remember having to open it in sensor only mode before this last version, but I don't think so.

Either way, problem averted!

Thanks for the quick reply!!!


New Member
Hello Ganesh_AT.

I impressive your plugin. But I found a little problem which annoy me and some question.

1. When I run RSM with default param (Just double click). Program always detect open "Open Hardware Monitor DLL found" whatever OpenHardwareMonitor run or not. Finally It 's throw exception "Please wait for the web server to start..An error occured while opening the HWiNFO shared memory! - Unable to find the specified file." and program exit.

2. From 1. I try to run OHM first, then run HWINFO and run RSM in the end. Yes, RHM looking work fine. He 's not display any error and webserver start successfully. But when browse to page eg . http://localhost:55555 Webpage return blank page. No data display. I try to check many time Firefox, Chrome, Edge and ensure sensor window in HWINFO is activated.

3. I try again but change to run HWINFO 32 bit version (HWINFO32.exe) and run same order in pt.2 Yes RSM work fine and return data. (My system is 64bit Windows 10 Home).

Finally. I have only one question.

1. What is the format of SensorUpdateTime ? Example I run program at 14:18 in my local time zone (Thailand) SensorUpdateTime report as 1520234293. How to translate this number into time.

Last Edit : OK I found your time format. It 's UNIX time.

Thank in advance


New Member
Hello everyone. I recently started using the Remote Sensor Monitor in one of the computers that I have in my network. It's pretty sweet. I can access what seems to be an object / JSON when I access http://machine_local_ip:port/. But I'd like to know if anyone knows how to add the CORS header ‘Access-Control-Allow-Origin’ in the API, web server.

I have other software installed in the same machine with APIs that gives me some other useful data. In my own laptop that is in the network I decided to create a simple HTML + JavaScript file that reads the results from these APIs and show me in the web browser. The problem is that I'm getting an error when I try to access the data from http://machine_local_ip:port/:

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://machine_local_ip:55555/. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).

Does anyone know how to circumvent this issue? Or how to add the header for this API?


New Member
Ganesh_AT said:

I wish to introduce Remote Sensor Monitor (a small freeware Windows console application (requires .NET 4.0) that I have been developing over the last week or so) for your feedback / bug reports.

Release Notes:
1. Added support for AIDA64 sensor / data reporting
2. Removed external DLL dependency for GPU-Z shared memory access


Release Notes:
1. Fixed bug related to certain sensors being reported multiple times in Hyper-V enabled machines


Release Notes:
1. Initial public release


Remote Sensor Monitor
Copyright (C) 2013 Ganesh T S

Remote Sensor Monitor is a Windows console application designed to present various hardware sensor parameters reported by HWiNFO / GPU-Z / AIDA64 / Open Hardware Monitor as a JSON string and make it available over the network. Enabling GPU-Z, HWiNFO and AIDA64 requires the programs to be running the background. The minimum supported versions are: GPU-Z: 0.7.4, HWiNFO: 4.30, AIDA64: 4.00.2706. Open Hardware Monitor sensors can be reported only if OpenHardwareMonitorLib.dll is present in the same folder as that of the application. Once the web server starts up, the JSON string is available at http://<IP>:<PORT> ; The reported parameters can be filtered / configured via the web interface at http://<IP>:<PORT>/config ; The program requires administrative privileges in order to open and close the applicable port in the firewall when necessary.

Command Line Options:

 p, port :    (Default: 55555) Port number to use
 hwinfo :    (Default: 1) Enable (1) / Disable (0) sending out sensor readings from HWiNFO
 gpuz :      (Default: 1) Enable (1) / Disable (0) sending out sensor readings from GPU-Z
 aida64 :    (Default: 1) Enable (1) / Disable (0) sending out sensor readings from AIDA64
 ohm :       (Default: 1) Enable (1) / Disable (0) sending out sensor readings from OpenHardwareMonitor
 h, help :   Display the help screen.


       "Remote Sensor Monitor.exe" [-p=<port_number>] [--hwinfo=<0|1>] [--gpuz=<0|1>] [--aida64=<0|1>] [--ohm=<0|1>]

With the JSON output, it is easy to develop client applications for various purposes. For example, the script hosted here: : can be used to record various sensor parameters of a remote machine on which this program is running into a CSV file.

The code itself is based heavily on SensorMonHTTP, a open source GPU-Z / sizegenetics-reviewOpen Hardware Monitor C# .NET application that I had developed earlier. It is hosted here: ; I have added HWiNFO support, thanks to the shared memory details provided  by Martin. I would have loved to open source this effort too, but Martin prefers that the shared memory specifications remain private. Therefore, this fork of SensorMonHTTP will have to remain closed-source.

Edit: It would be great is someone could contribute an icon / display graphic for the program.

Hi Is anybody using this tool?
I find that the program will randomly stop and there is no way to know the state of the program.


New Member
I'm having a bit of an issue with the server. Whenever I try to start it I get this error

How do I fix this?

I'm running HWiNFO64 v5.86-3480 configured as such:

EDIT: Somehow forcefully disabling the OpenHardwareMonitor integration fixed the issue even though I do not have OpenHardwareMonitor running.
Thanks for the program! :)

But... I am having issues with decimal values. To be more specific, it's outputting a decimal comma in float numbers instead of a decimal point. It seems to be ignoring the settings in the main program, and instead it relies on the system's regional settings.

Is there any way to force it to use . (decimal point) in its output - without having to change it in Windows settings? Perhaps add a command line option? Or even let it use the same setting as in the main program.