Missing EVGA GPU ICX in in latest version(s)

Hi Martin,

It's the ICX special info, and includes the extra 9 sensors and both gpu fan readings.

I'm not sure when this stopped, but it was some recent version ago. I set things back to stock (bummer, lost many of my customizations) but I do have a .reg file I can try loading again. I replaced the .ini file also which I usually don't do to test and the info is not showing.

I ran my oldest at hand version 557_3235 and that did show them. Something has changed.


PS: I have versions from the above noted to 571_3320 readily at hand if you want me to run another.
AFAIK the problem is that sometimes the iCX devices don't show up in HWiNFO, and sometimes they do. But it's not yet fully understood why this happens...
I don't think this is a problem of new HWiNFO versions, as there was no (direct) change in this area for some time.
Can you please attach the HWiNFO Debug File when it fails ?
Strange because I can consistently get the ICX info in 3235 but not in the latest, which is where I noticed it missing. But I haven't used the older version yet without the ICX info being there so it was consistent back when.

As to the Corsair. I consistently have the Corsair info in there in both HWi versions. The only issue I consistently have had is that HWi turns off the PSU fan when it has been running. So, the workaround has been to run Corsair Link AFTER HWi is started.

I just now, in the middle of this post got an update notice from Corsair, so will report back if anything has changed.
Everything is the same. Trying the new Corsair option under Settings/Safety I actually see no difference. Checked and Unchecked seem to be the same. The Corsair items are all still there in both and as previously, the running PSU fan is turned off if it is spinning (with or without CL running) and the FAN is the only thing not showing in the Corsair section. By either restarting CL or simply right-click the task tray icon and re-selecting the same profile as is already 'loaded' the fan will start up and the line item will show in HWi
Here's two debug files. One with Corsair checked, the other without. The Corsair info appears in either one.


  • HWinfoDebugBubbismith.7z
    66.1 KB · Views: 2
Thanks. I can see now where both problems are.
1. For disabling Corsair Link, this will require an update in HWiNFO. I will fix this in the next build.
2. For EVGA iCX, please try to "Reset GPU I2C Cache" to see if that will help. If not, try to disable "GPU I2C Caching" and let me know the result.
Thanks Martin.

I tried those options but it did not change the Corsair Link options, they all show up but the PSU Fan. There was no ICX info on either of the two most recent builds.

I went back thru some versions and found - hw64_571_3310.zip is the last one where it seems to be fine with the Corsair and ICX display. The last two versions since do not display the ICX info, even with the I2C options on or off w/without the I2C Cache cleaned.
Thanks for the feedback.
Using the latest build, please try the following: enable Debug Mode and do "Reset GPU I2C Cache". Then run it, close and attach the new Debug File created.
OK, here's the dbg, I had it open, clicked on Debug Mode, then clicked on GPU I2C Caching, then reset the above. Wasn't sure if the GPU checkbox was to be checked or not.


  • HWiNFO64-BubbiSmith-Reset GPUI2C.7z
    39.3 KB · Views: 1
Thanks. This is really strange... Just to make sure - every time you made changes to HWiNFO configuration, have you also restarted HWiNFO before ?
Another dump that I'd like to see is with the "GPU I2C Caching" option disabled.
I start hwi, make the changes you ask for, 
close hwi

I then delete any previous debug file, 
then restart hwi, 
close hwi, 

then send the dbg file.

Let me know if I should modify this?

Also, the sweet spot is v3310. It reads both the Corsair and the ICX info.
The ICX is a real mystery, also because between build 3310 and later ones there was no change in that area.. I really don't understand what could have influence on this...
So if you start build 3320 you get no ICX sensors and starting build 3310 right after that will show ICX ? Can you also please attach a DBG file from 3310 ?
Hmmm... It might be something odd with my setup here? Asus x99 Deluxe II. I just ran the 3310 and as I noted ICX and Corsair work well. Only issue is Corsair PSU Fan (HX850i) shuts off when HWi runs. Simply starting CLink4 or if it is running right-click the tasktray icon and select my custom profile and it starts up and HWi sees it running.


  • HWiNFO64-V3310.7z
    39.8 KB · Views: 1
  • HWInfo-3310.png
    58.3 KB · Views: 2
  • HWInfo-3320.png
    40.3 KB · Views: 2
Thanks. I think I finally found something :)
Will make a change in the next Beta build for the ICX. That build will also include an update for Corsair PSU, so that when the "CorsairLink and Asetek Support" is disabled it won't access the PSU to avoid the problem with its fan.
Hi Martin, yes, did check it and I believe it works the way you would like. IE: No Corsair info if CorsairLink... is unchecked. With it checked it works as it has previously, ie: I still get my PSU fan and all other Corsair info. (and no complaint messages, etc running both at the same time)

It still turns off my fan if HWi is started after Corsair is run. So, as has been, I start HWi and then after - Corsair Link using a 30 second delay.

FYI - small rant: CorsairLink does one thing well, if you start it to start the fan spinning (ie: with a profile that spins the fan at low temps) you can quit CorsairLink and the fan keeps running. EVGA on the other hand are cr*p, and insist on stealing processor bits and it must remain running or the fans go back to the stock profile.