Not sure if a bug

darkgenz

Member
Hwinfo does not display my ancient Promise TX4650 fake-RAID SAS controller in disk list (neither as single huge disk or as separate disks). The connected disks are Sun/Oracle branded 3Tb Seagate Constellation ES2 (SAS interface).
For comparison, here is screenshot from Speccy, which displays it correctly, but have many other issues.
 

Attachments

  • hwinfo.png
    hwinfo.png
    95.8 KB · Views: 9
  • speccy.png
    speccy.png
    152 KB · Views: 8

Martin

HWiNFO Author
Staff member
I don't see any of those disk reported in Speccy, only the logical RAID array.
Enumerating individual disks managed by such RAID controllers can be really tricky as the interfaces used are proprietary.
If you would attach the HWiNFO Debug File I can have a look at that, but chances are rather low.
 

Martin

HWiNFO Author
Staff member
 

darkgenz

Member
Unfortunately, still no success.
The dbg file of new build also attached.
 

Attachments

  • HWiNFO64.DBG
    1.7 MB · Views: 1

Martin

HWiNFO Author
Staff member
Then I'm sorry, but I don't have information how to support this proprietary controller. I tried it with methods for previous generations, but it didn't work out :(
 

darkgenz

Member
Then I'm sorry, but I don't have information how to support this proprietary controller. I tried it with methods for previous generations, but it didn't work out :(
Actually it is rather old controller, its bios mentioning something like (2006-2010), and as far as i remember, it was sold at these years, maybe untill 2012.
OK, thank you for atleast trying. I'll also check that build with 2nd controller in JBOD (separate disks) mode, maybe it will work.
 

darkgenz

Member
Well, tested it in JBOD mode.
At least, now HWINFO can provide drive list, but not the model and capacity.
Anyway, thank for your time.
 

Attachments

  • hwinfo.png
    hwinfo.png
    98.4 KB · Views: 5
  • HWiNFO64.DBG
    1.4 MB · Views: 1
Top