Please help: my HWinfo has lost the "charge rate" and "estimated remaining time" battery stats

I had them as part of my overlay, I have no idea what happened but out of the blue they are not even listed in the sensor screen of hwinfo and I can't seem to get them back. I tried a lot of things, including a system restore, but nothing worked. I also tried to reset preferences in the main settings, no luck. They are not listed as available stats in hwinfo anymore and of course can't be passed on to other apps. Hwinfo is latest 7.66 portable version.
If anyone could help me get back those two values, I'd greatly appreciate it.
Availability of these values depends on BIOS and drivers. Have you maybe performed an update there when these values disappeared?
No, they disappeared today and I didn't do any update to those. I did notice that my charge rate had an abnormal 490 max and it had stopped reporting current value. i then rebooted the system and both values were gone from the list. After googling I found topics about reseting preferences and list order, I did both but no help. Is there a way to clean the registry from every single entry? Does "reseting preferences" do that even for the portable version? While messing around trying to fix it, I clicked uninstall driver in hwinfo menu, but that didn't seem to help...
Try to completely power off the system, remove the power cord for a minute and start again.
I've rebooted the system multiple times. But I have no power cord to remove, it's a Lenovo Legion go (kind of like a laptop) with an internal battery that can't be easily removed. Is there any way to remove all registry entries? I've even installed using the installer version, uninstalled this, but no help. Is there a log or something that I could do to help troubleshoot the cause? I saw in some posts where you replied that if hwinfo gets a bad value it deleted the stat and keeps that flag in the registry. Could that be my issue?
You can try to completely "Reset Preferences" in HWiNFO but I don't think this is a problem in HWiNFO.
Yes, unfortunately I've tried that and to reset the order list but those didn't help. Are they supposed to completely delete all registry entries even for the portable version? Is there anything I could do to troubleshoot the issue?
Yes, such crazy values might mean some problem happened in the notebook, more precisely its Embedded Controller.
Try to upgrade the BIOS, that might also reset the Embedded Controller or upgrade its firmware.
Woot, the problem fixed itself somehow after I plugged in a charger! I had tried pretty much everything but that, I guess the reverse of unplugging and letting it run out of juice triggered an update to those sensors somehow. Thanks for your replies and the support!
(PS: if we could get an optional setting to toggle off the start warning notification for the 32 bits version, it'd be great)