Stop in the "Enumerating Buses ..." at the startup of HWiNFO64


New Member
(I'm sorry. I am not good at English. Please forgive the use of the translation site.)

As of the title, startup dialog (progress bar) is will stop in a state of "Enumerating Buses ...".
When the "Sensors-Only Checked" or "Summary-Only Checked", it was started without any problems.

Would you have any solutions or best practices?

It will attach a debug file. Version I've used is "HWiNFO64 v5.10-2700".
(So it could not force the end of the process, and then restart the computer.)



    64 KB · Views: 3
There seems to be a problem enumerating USB devices under the ASMedia USB 3.0 controller. Can you please try to upgrade its drivers ?
RE: Stop in the "Enumerating Buses ..." at the startup of HWiNFO64

Thanks for reply

I tried to change version of ASMedia USB 3.0 controller as follows.

(1) ASMedia USB 3.0_ASM104x: ver1.16.16 (first time version)
(2) ASMedia USB 3.0_ASM104x: ver1.16.12 (motherboard recommended version: "ASUS Rampage IV Extreame")
(3) ASMedia USB 3.0_ASM104x: ver1.16.29 (latest version)

However, the results did not change.
(it will attach a debug file of the state that have been (3) applied )

As additional information
When disable the USB device (ASMedia USB 3.0), HWiNFO64 was started without any problems.
But, I use the USB port, so it's hard to remain disabled.

I understand that there is a problem with ASMedia USB 3.0 controller.
I have no problem not see the information of this device.
In order to successfully launch the HWiNFO, or there is no way to skip such a device?


    63.8 KB · Views: 1
Thanks for the test results. What exactly does the happen when you run HWiNFO - does it just hang and not move further, or does HWiNFO crash with a Windows message that it stopped responding ?
It's also a bit difficult to diagnose this issue without having direct access to the machine for debugging. The current Debug File doesn't offer enough information to determine the exact cause, so please run this build: and attach here the new DBG file produced.
RE: Stop in the "Enumerating Buses ..." at the startup of HWiNFO64

When running beta version,it was a different result.

Previously it had been stopped at the "Enumeration Buses...".
In the beta version that I got from Martin this time, we now stop at the "Flushing buffers ...".
(Please see the attached figure.)

Once HWiNFO stops as attached figure, task bar of the title will be "Analyzing ... (Not Responding)".
When I click on the progress bar, it will appear Windows dialog such as "HWiNFO64 is not responding"

I even went to kill the process from the Windows Task Manager, HWiNFO does not disappear.
The following command also tried to run, but it will be the same result.
# taskkill /F /T /IM "hwinfo64.exe"
(Returned "success", but it does not actually hwinfo64.exe disappeared)

Since the debug files in this state is locked, I had to restart the computer.

If there is a file to be submitted to the other I want to cooperate.
I'm sorry. After this reply will be delayed a little response.



  • stop_by_version.png
    16.2 KB · Views: 3
    66.6 KB · Views: 1
Well, this is a really strange issue that I haven't seen before. HWiNFO is using standard queries to determine what USB devices are attached and there should be no reason for such a hang.
I see one of the ASMedia USB 3.0 controllers has a device attached to it, but querying more details about it causes the hang. What device is that, the vendor seems to be Century, but I couldn't find more information about it ? Can you also try to detach it if possible and see if that helps ?
RE: Stop in the "Enumerating Buses ..." at the startup of HWiNFO64

Thanks for the help. And I'm sorry to late.
Cause it was found thanks to the Martin tips.

Vendor of the device that Century is a sub-display that I have used.
The product name is 'Century plus one LCD-10000V'.

The video signal input of the sub-display is a D-sub 15pin.
But, it was only to connect the USB for power supply of the display.
Assignment of this USB Port is ASMedia USB 3.0 Port.

As a result of changing the USB port of the assignment , HWiNFO64 has started successfully.
I have changed the assignment port to non- ASMedia USB 3.0 controller.
I did not know, that HWiNFO64 is scanning the USB device in connection.

Remains in this state , I will continue to use the HWiNFO64.
Thank you for handling the matter.
Thanks for your feedback. Well, sometimes some components don't play nice together ;) But I'm glad it's resolved now.