Vega 56 (Vega Nitro+64 bios) freezes the computer when enable "i2c support force" monitoring for vrm

liszt17

New Member
Hi! Title says all. Newest HwInfo (6.30-4240) and newest radeon software (20.8.3).
The problem presents since 20.3.1 driver, before I use 19.1.1 and a previous version of hwinfo, and worked perfectly, never freeze, saw the vrm1&2 temps, voltages, etc. But I had to update for doom eternal.
There is no problem at all, when "i2c forced" diasbled, but I cannot see the vrm temps. But I want to monitoring them also. Is there a workaround for vega cards to solve this problem?
Thanks.
 

Martin

HWiNFO Author
Staff member
Sorry, there is no workaround for this case and it's also the reason why this setting is disabled by default. AMD drivers were not designed to allow others accessing those devices via I2C, so when it worked you were lucky.
Vega GPUs usually report VRM temperatures also without the need to use I2C - "GPU VR VDDC Temperature" and "GPU VR MVDD Temperature".
 

liszt17

New Member
Yeah, maybe, but in my case, they simply not showing anything, or don't apperar at all. Like now. I checked in hidden items, but they won't showed there also.
But there is a thing: when Im enabling the "i2c forcing", the blackscreen appears, and gpu fans start to spinning at 100%. When the compruter restarted, not always, but some occasions showing the vrm temps, but after a while, the black screen appears again. Also, the hwinfo lagging a bit before.
So I'm simple unlucky, and have to accept it? That is sad :(
 

Martin

HWiNFO Author
Staff member
Yes, the crash happens because synchronization between HWiNFO and GPU drivers for I2C doesn't work and when both access the I2C a collision happens.
 
Top