Asus X670e-i Chipset Temp not showing up


New Member
Is the ASUS X670e-i board fully supported? "ASUS ROG STRIX X670E-I GAMING WIFI (AMD Chipset)" shows up as a sensor category, but no temp sensor is displayed or chipset temp.


this is what shows up only
If the Chipset temperature is not shown then it's because the BIOS didn't properly set up the chipset for temperature monitoring.
Try to upgrade the BIOS.
Hmm, then I think the BIOS doesn't enable chipset monitoring for your board. You might try to contact ASUS support to add/fix this.
Hello, I'd like to bump this topic. I have the same problem, HWiNFO does not show chipset temperature for ASUS X670E-I. Note that there is a sensor and the ASUS Armory Crate application is showing the temperature of primary chipset from within operating system (for completeness, monitoring screen in BIOS shows temperature of both primary and secondary chipset).

Screenshot of Armory Crate showing temperature of chipset:
Screenshot 2023-04-03 090831.jpg

I'm attaching the report and debug file. Thx for looking into it!


  • HWiNFO64.HTM
    253.9 KB · Views: 4
Hmm, not sure what I did before. Now I run system info and sensors with debug on and the resulting file is only ~5MB and compressed ~1.5MB, so attaching here...


    1.4 MB · Views: 1
HWiNFO supports reading Chipset temperature on these series but for some reason it doesn't work here.
I'm wondering whether this might be due to Hyper-V / Core isolation. Please try to disable these feature if that will help.
Tried to disable this, rebooted, but it did not have any effect. Attaching new DBG for just in case...

Screenshot 2023-04-03 121202.png


    1.1 MB · Views: 1
Thanks. Please try this build and let me know if it maybe shows it now:
Hello, much better :

Note that this Chipset labeled as Chipset 2 in HWiNFO corresponds with Chipset 1 in Armory Crate and according to the temperature it is most likely the primary chipset. The secondary chipset (aka Chipset 2) is always cooler than the primary one.

On unrelated matter: ASUS EC: ASUS sensor only shows VRM temperature in my case. I saw on some other ASUS x670 boards it was also showing VRM current and power and some other stuff, so I wonder if these could be made available too.
You're right, there are 2 instances of the chipset and in your case only the second one provides temperature. ASUS seems to address them the other way around.

Not sure if your board also supports VRM monitoring but I will add in onto the list in the next (Beta) build. If it does support this feature, you will see the respective values.
Anyway, thank you so much for your help so far, chipset is difficult to keep cool on this board and having it's temperature in HWiNFO is a relief. I'm sending a humble donation.

Zdravím z Moravy na Slovensko!
Hi, I need to bump this thread because the same issue is still present with Asus B650E-F on the latest beta of HWinfo64, v7.67-5285 as of 12/8/2023. I double checked, it isn't hidden (I only hid RTSS.) Any ideas?

missing temperature.png
Problem here is that the BIOS didn't enable this chipset sensor. Try to upgrade the BIOS to latest version, maybe it will fix it.