Autostart fixed ?

PhotM

Well-Known Member
Hi Martin, :angel: Folks,

:p It's true, you have it working. I tried it several times and it started each time. As far as the UAC, I don't know how others are doing it but they are getting around it; System Explorer, Smart Doctor(it does a scan too.) do. I named those because when ever they are started manually then UAC happens. When ever CCeaner, System Mechanic are started manually, they now bypass the UAC, where they didn't used too, just incase your interested. This would become an issue it one was using auto log in.

Anyway thanks again, :D

Crysta
 

Martin

HWiNFO Author
Staff member
I'm not sure how those tools are getting around UAC, but maybe they put itself into the Task Scheduler? Should be easy to check...
 

PhotM

Well-Known Member
Martin said:
I'm not sure how those tools are getting around UAC, but maybe they put itself into the Task Scheduler? Should be easy to check...
Sometime when I am not so busy, I will hunt around and see ..... :D But that wouldn't be the case on a manual start???? Later Martin..... :)

Crysta
 

Martin

HWiNFO Author
Staff member
Please try the following after moving the files:
- Uncheck the "Auto Start" option and click OK
- Check the "Auto Start" option and click OK
 

aMduser

Member
Hi all , i put a 30 second delay on my startup as i have a bit going on when W7-64 starts up ..

Everything is going great , thanks .....
 

Attachments

livin

Member
I installed HWinfo64 beta 1770 on two separate (Dell desktop & HP laptop) Win7 x64 PCs... 'Auto Start' does not work on either one. I have tried deselecting/reselecting the Autorun option, restarting, etc... it never works.

The only thing I really need is for the fan settings to take hold... any ideas on how to get it working?

thx
 

Martin

HWiNFO Author
Staff member
Did it work with the latest stable version 4.06 ?
Can you try to disable UAC if that changes anything ?

livin said:
I installed HWinfo64 beta 1770 on two separate (Dell desktop & HP laptop) Win7 x64 PCs... 'Auto Start' does not work on either one. I have tried deselecting/reselecting the Autorun option, restarting, etc... it never works.

The only thing I really need is for the fan settings to take hold... any ideas on how to get it working?

thx
 

livin

Member
Martin said:
Did it work with the latest stable version 4.06 ?
Can you try to disable UAC if that changes anything ?

livin said:
I installed HWinfo64 beta 1770 on two separate (Dell desktop & HP laptop) Win7 x64 PCs... 'Auto Start' does not work on either one. I have tried deselecting/reselecting the Autorun option, restarting, etc... it never works.

The only thing I really need is for the fan settings to take hold... any ideas on how to get it working?

thx
I did not try the latest stable version, I just started using (just found) HWinfo... I had been using Speedfan but is it buggy as all get out. I can say, your app is VERY nice and seems to work very well - thank you!

I have not disabled UAC - I'd like to keep in enabled, just for the added layer of security, especially on my main system.

If I move to the 32bit version, is autorun working for it on Win7 x64?

Will putting it in Scheduled Tasks (run on boot) make it work properly?
If yes, what is the command line needed for it to start, trigger the fan settings, and stay minimized?

thx!
 

Martin

HWiNFO Author
Staff member
Yes, putting HWiNFO into Task Scheduler for autorun will work, moreover if configured properly it will allow you to bypass UAC so the UAC prompt will not appear during every autostart.
There is no specific command line required for HWiNFO, it keeps its settings in registry and own INI file.
 

livin

Member
Martin said:
Yes, putting HWiNFO into Task Scheduler for autorun will work, moreover if configured properly it will allow you to bypass UAC so the UAC prompt will not appear during every autostart.
There is no specific command line required for HWiNFO, it keeps its settings in registry and own INI file.
Does 'Auto Start' need to be checked?
Does it need to run under SYSTEM?

thx
 

Martin

HWiNFO Author
Staff member
If you manually configure Task Scheduler to start HWiNFO, then you should not enable "Auto Start" in HWiNFO.
 

aMduser

Member
delmanicomio said:
no need to task scheduler
because martin fixed it and working great

we are waiting new full version
Hi , you have misread what i type .

My system is very busy at start-up , so i put in the delay for this system , now it is 10 seconds ...
 

livin

Member
I just installed 4.08 and I still cannot get autostart to work properly...

It does start up, but it invokes UAC so I must accept the warning... then the fan speeds don't kick in until I manually open the sensor and click the 'fan' button.

All I want is for the fan settings to take effect when I log in... can anyone post a step-wise method on how to get this to work automatically?

thank you
 

Martin

HWiNFO Author
Staff member
To avoid the UAC popup, you need to configure HWiNFO using Task Scheduler (as already discussed in this thread).
Once you have HWiNFO autostart setup, to automatically start the fan control too, you need to put the following entry at the end of the HWiNFO32/64.INI file:
OpenFanCtrlMin=1
Just make sure this entry in under the [Settings] section. You can edit the INI file using notepad or any other text-editing tools.
 

livin

Member
Martin said:
To avoid the UAC popup, you need to configure HWiNFO using Task Scheduler (as already discussed in this thread).
Once you have HWiNFO autostart setup, to automatically start the fan control too, you need to put the following entry at the end of the HWiNFO32/64.INI file:
OpenFanCtrlMin=1
Just make sure this entry in under the [Settings] section. You can edit the INI file using notepad or any other text-editing tools.
... this does not work for me. I still get a UAC Popup when I launch it. Manually or Auto.
 

tostitobandito

New Member
Apologies for the thread necromancy, but this seemed like the best place for my question.

I'm using an Alienware M17x R3 with a recently-installed AMD 7970m on Windows 7 (UAC is off and I'm an admin). This card has necessitated the use of HWINFO64 for fan control since my system fans no longer function properly post-GPU upgrade.

Anyways, I've got it running smoothly now with the stupid Dell EC disabled. I can control both fans at once at 0/2400/4000 RPM using the profiles. However, I'm having problems with getting it to both start with windows automatically and have the fan profiles active without any intervention.

First, the auto-start checkbox isn't doing anything for me. It doesn't start with Windows.

Second, when I do start it with windows either via task scheduler or the startup menu, it starts and minimizes all its windows to the tray just like it should but when I task the GPU or CPU the fans don't function. I have to open up the sensor window and open the fan window for the fan profile to take effect. Once I do that I can minimize again and the fans will continue to work until the next reboot.

Any ideas?

Thanks!
 

Martin

HWiNFO Author
Staff member
When you activate the "Auto Start" option, it should create a new task in the Task Scheduler. Please check if it's there.
As for automatically applying custom fan options, make sure the "Show Sensors on Startup" option is enabled and add the following line at the end of the HWiNFO64.INI file:
OpenFanCtrlMin=1
That will automatically open the fan control window too and apply your settings.
 
Top