Black screen after using hwinfo32 (including bios infos)


I do have a problem after selecting the sensor page the screen flickers and becomes dark (started HWINFO32 in Debug-Mode, sorry data is lost), no more reactions of the system. Had to reboot by switching the 8730w off by pressing the on/off button for at least 4 sec. After this I do not get a visible information on the LCD anymore. During start up it is visible that the back-light switches on. But no letters are visible.

My system: 8730W, W7 64 Ultimate, Dreamcolor, 8GB RAM.

Tried the following things:
Reset bios CMOS Ram: No success.
Reset bios to standard values: No success.
Hard reset of the system by removing all power-supplies and pressing on for at least 15 sec: No success.
Connected to an external LCD: Everything seems to be fine.
Installed latest BIOS F.13: No success
Installed latest Driver for the FX3700M: No success.
Switched resolution of the graphics to a different solution: No success.

Now I have done everything I can think of. :oops: :evil: :cry:

Any ideas?

I'm sorry that such thing happened, and I have no idea why.. Maybe if you would recover the HWiNFO32.DBG file which should reside in the HWiNFO32 folder I could have a look if I find something there.

So only the LCD is not responding and the rest of machine works ok?
Doesn't even the BIOS display something?

Seems you have tried many possible options, maybe I would add:
- Check in BIOS and try to change the display output.. maybe something with the switch?
- Remove power supply, battery and if possible the coin cell battery too for a while (this might require to disassemble the notebook), but since you resetted the BIOS CMOS I assume you did this already.
- Check on if there are users with a similar issue (I see you already posted there...)
Thanks for your reply.

The BIOS does not display anything.

I checked the graphic card with an external monitor and everything is ok on it.
I did all the things you mentioned regarding the power supply.
And I asked the question already there.

Maybe I can gather informations by running hwinfo a second time. Let you now.
I didn't understand one thing.. when you attach the 2nd LCD does then the primary work as well, or you're just able to work with the secondary? What says the nVidia control panel, does it recognize the primary display and have you tried to switch between display cloning?
The LCD of the NB does not show anything. Even in cloning mode the external monitor has some informations. The nvidia panel does show the correct informations of the panel. I will add the latest DBG file.
Do you have any idea to reset the nvidia bios or even flash the latest bios?


    71.8 KB · Views: 43
The DBG doesn't reveal any suspicios behavior, no crashes, etc..
Is there a CHiL (CHL) chip on the GPU?
and 2 more questions:
1. Have you run HWiNFO32 in normal mode (without Debug Mode) before? If yes, did it work then and caused this issue only after running it in Debug Mode?
2. Have you ever disabled the "GPU I2C via NVAPI" ? I wouldn't advise to disable that.
Yes I did. But I had to reset the NB as described before but everything was fine after rebooting.
And no I do not know. What happens if I did?
Sorry, I don't understand :) is that the answer to the 1. or 2. question?
I need to know exactly the behaviour - if/what happened with/without Debug Mode and if you even disabled the I2C via NVAPI.

ubmtdc said:
Yes I did. But I had to reset the NB as described before but everything was fine after rebooting.
And no I do not know. What happens if I did?
Yes I tried HWINFO32 before without debuginformation. Result screen flickers, shows multiple colors and cube in different color and every information on the screen went off. Had to restart the NB with the result of booting without any problems.
Afterwards I used the debug version. Same behaviour as above but a little bit slower. The result here is described in the first post.
Thanks for the clarification.
Have you ever disabled the "GPU I2C via NVAPI" option or never changed that?
Then it seems there might be some weird voltage regulator chip on the GPU that even when accessed (just read) causes issues.
I can only advise to try to reflash the Video BIOS (but for exact instructions better search on notebookreview or techpowerup) and if that doesn't help -> RMA
I'll also implement some workarounds in HWiNFO32 to avoid even accessing such crazy chips.
.. and as long as you haven't disabled the "GPU I2C via NVAPI" setting, the VR was accessed via NVIDIA interface, so that might mean the chip being faulty when causing such things..
I agree that this points to a serious flaw in the nVidia design. Any disruption by software should only be temporary. I cannot imagine a command could "fry" a component. If so, it would indicate a serious lack of hardware safeguard.

Hopefully it is simply an undocumented, inaccessible command that can only be implemented by the manufacturer addressing the hardware at an even lower level than what is possible using "consumer-level" firmware updating.

BTW, the latest beta, 3.66.1093 does correct the flashing black screen issue on my machine (HP 8730w, nVidia Quadro 2700FX with 512MB Ram, Dreamcolor screen) when selecting "GPU I2C Support". I am cautiously conducting further tests to try other settings and will report back later.