Corsair psu monitoring issues

carmonben

Member
3 separate issues
first issue is hwinfo will crash on startup with this error "0xc0000417",
the second issue is that hwinfo will randomly crash after a while, however it will only happens when it detects the corsair psu.
third issue is it sometimes wont detect the corsair psu (and it doesnt crash)
I have a dbg file for error 2 but it wont upload, attached is the log for error 1

I do not have any corsair software installed any more, and know that it is corsairs' fault, but it would be nice if the hardware was useable...
thank you for your time,
Ben


here is the event viewer log for error #1
Faulting application name: HWiNFO64.EXE, version: 6.34.4300.0, time stamp: 0x5fa14a50
Faulting module name: HWiNFO64.EXE, version: 6.34.4300.0, time stamp: 0x5fa14a50
Exception code: 0xc0000417
Fault offset: 0x000000000023b6bc
Faulting process id: 0x4b20
Faulting application start time: 0x01d6cd32aefb263e
Faulting application path: C:\Program Files\HWiNFO64\HWiNFO64.EXE
Faulting module path: C:\Program Files\HWiNFO64\HWiNFO64.EXE
Report Id: c8d7aceb-1cee-4553-87e5-2932132e2c57
Faulting package full name:
Faulting package-relative application ID:
 

Attachments

  • HWiNFO64#1.DBG
    1.9 MB · Views: 1

carmonben

Member
oh and heres what it looks like when it doesnt detect the psu at all
 

Attachments

  • HWiNFO64#3.DBG
    2.4 MB · Views: 1

Martin

HWiNFO Author
Staff member
The only thing I can do here is to look how to fix HWiNFO crashing. But for that I need to analyze the respective Debug Files.
For problem #1 the file you provided doesn't indicate a crash, but ordinary closing. Are you sure you haven't run HWiNFO again after the crash? That would overwrite the previous file.
Please try to gather such files from crash and compress them (ZIP, RAR, 7z, etc.) before attaching.
 

carmonben

Member
ah that worked, this is from the time it crashed after being able to read the psu
 

Attachments

  • HWiNFO64#2.zip
    1,006.1 KB · Views: 1

Martin

HWiNFO Author
Staff member
Do you maybe have a custom multiplier set on some of the Corsair values? Please try the latest HWiNFO Beta build (v6.35) if that will crash.
 

carmonben

Member
Yes i do have a custom multiplier set on the 12v rails to convert from amps to watts, i also have most of the values disabled for monitoring because they take so much profiling time.
im now on the beta build and will let it run to see if it still crashes, i will reply again if it does, but it has been 5 minutes which is a good sign
Thank you so much for helping, and for working to make this great software.
 
Top