HWinfo makes update corsair watercooling glitch during update

TheLichCrow

New Member
Hello

When I wanted to update the firmware of my corsair Icue H115i RGB pro xt AIO watercooling I have a bug and the update could not continue. even with the files to force the update.
The watercooling was no longer detected.
So panic on board, but fortunately the H115i, even without firmware works, there was just no more regulation.
By switching off HWinfo, it was possible to force a flashing of the controller and everything works again.

I'm posting here so that if someone has the same problem, a little internet research will help them to know how to solve the problem

Have a nice day
 

Dom

New Member
I have a bug that goes in a similar way. After updating to beta 7.01 4420, whenever I hit the reset timer button, my water temp sensor which is attached to a corsair commander, glitches and gives me a zero reading (which means loss of communication) it will only last a couple mili seconds but long enough to be picked by the HWinfo graph I have for it and be registered with a zero value as a minimum for that sensor.

Rolling back to version 7.00 stable remedies the issue, so something must have changed in the way corsair stuff is communicating with hwinfo or something is being blocked for a fraction of seconds for this reading when reseting the timer in between version 7 and version 7.01 4420.

And no I do not use icue!
 

Martin

HWiNFO Author
Staff member
There was no change in Corsair communication protocol or its access between those versions.
This is rather due to a change in how the actually measured values are reset, I will try to fix this in the next build.
 

Limy

Member
I think it's probably HW Info 64 and latest/recent iCue software. I use haptic headphones which use the iCue software for full funtionality. For now I have stopped using iCue because if I run it to make the headphone use a certain EQ preset for example, anything at all really, windows maintenance goes into a loop and never stops. Stopping the services for Corsair iCue, 3 of them, just for headphones!!, solves it.

Then when stopped,
Windows will set not change the audio driver, but it changes the setup of the sound properties. (Corsair WITH iCue creates an 8 channel (surround profile) strange as the headphones are only stereo, but it uses the others to make various EQs sound better, my guess.) Continuing with iCue off, a proper 2 channel profile with windows sonic (if I wish) can be used. Please note a similar set of Corsair headphones is virtual surround so 7.1 or 8 channels is expected. Mine are strictly stereo, with the implementaion of haptic feed back.) HS60 Haptic stereo game headphones. The main reason for the high price is one of the few headphones to add proper haptic (vibrating like rumble on a controller) for base tones. It adds real depth, but it depends on the game. One reviewer explained it as having a subwoofer strapped to your head! I agree. Released October 2020. Not worth it unless you want haptic which really is an experience, but not suitable for everything. It can easily be switched off without software. I guess love it, or hate it kind of thing. Only EQ profiles, presets, or your own need iCue. Haptic is adjusted on the cans and hardware implemented.
It's actually better for rock music, excellent I would say, with games it depends on the game. The haptic is strictly on the strength of below 80Hz sound, down to 15Hz. Excellent for SOME games and base heavy music. Sorry, the haptic is not the reason for this problem, but it's easy to confuse the similar HS60 Surround with the HS60 haptic, newly released October 2020. Haptic does not require iCue.

There are a few other oddities with both running, but takes ages to explain. Its best to say simply that iCue becomes "weird," and unstable when also running HW Info 64 (never used 32bit).

So that is basically what happens. I don't know for a fact why this happens, but I do know iCue can control many devices and is deeply integrated into the PC. I blame iCue for this not HW Info. I can't imagine how this could be solved by an update to HWInfo. I assume it's always going to be like this. I can easily live with it, but for those who use iCue for lights, sound, pump, AIO keyboards and more corsair products which can be tuned with iCue will simply have to stop using HW Info, or trouble shoot. (Or turn off iCue, but for an AIO for instance, you would have no way to control the AIO)

I don't like iCue. It's too intusive and installs everything regardless of what hardware can use it.

Summary. I am sure it's an issue of running HWInfo and iCue at the same time. I have tested extensively. The reason, is pure speculation so I won't say what I think, and even if I was correct it would not solve the problem.

That's my two cents. I don't know why. But, iCue does not like HWInfo. I fully blame iCue for this - not HWInfo which has never caused any issues since I started using it many years ago.

Extra: One thing I have not tried is to use a similar program to HW Info and see if that also makes iCue go bannanas? Cant add more but will try and answer any question.
 
Top