Lost CPU Fan Speed Sensor Reading


I think I was previously using v4.17

That was an older version that I just updated to version v4.24-2000 today. This new version does not show my CPU fan speed in the sensor Status display. v4.17 was just fine.
RE: Lost CPU Fan Spped Sensor Reading

Please look at the bottom of the sensors list if maybe it's there..
If not, please attach the Debug File.
RE: Lost CPU Fan Spped Sensor Reading

Attached is the debug file.

I have 4 fans controlled by the IT8720F chip. CPU is fan 1, Big exhaust is fan 2, small fan is 3 and the intake fan is fan 5. Only the fist two fans are controllable (I use speed fan to control them). The two uncontrollable fans show on the sensor status report - the two controllable fans (CPU & Big Exhaust) do not. On the older version of the HWINFO64 all 4 fans showed up.
RE: Lost CPU Fan Spped Sensor Reading

I believe this might be somehow related to the fact that those fans are controlled (by SpeedFan).
Are those fans maybe reported by HWiNFO when they are not controlled (after reboot, etc) ?
RE: Lost CPU Fan Spped Sensor Reading

Same behavior without speedfan or any overclock. Attached is the dbg file and a screen capture (old version would show all 4 fans here).
RE: Lost CPU Fan Spped Sensor Reading

Are there any other tools (like AIDA64 or CPUID HWMonitor) able to report those two fans ?
RE: Lost CPU Fan Spped Sensor Reading

Attached is Capture1 - showing CPUID (still withOUT speedfan running.

Capture2 shows the same thing - only with speedfan running (and commanding the CPU and Big Exhaust fan to zero - because the tempatures are at my minimum and the fans do not need to be running).
RE: Lost CPU Fan Spped Sensor Reading

Sorry, but I see only the 2nd capture.
Anyway, when running both HWMonitor and HWiNFO concurrently, thse fans still don't appear in HWiNFO ?
RE: Lost CPU Fan Spped Sensor Reading

Attached is both monitoring programs running at the same time (speedfan disabled and not running).

Note the strange missmatch. It appears that HWINFO is still not showing the CPU fan - but is showing the intake fan (that fan is not controlled and always reads around 1000 RPM). CPUID on the other hand seems to show the CPU fan (which if I recall w/o speedfan runs around 2000 RPM) - but not the intake fan (strange).

As a note - I re-enabled speedfan - which then sets the CPU and big exhaust fan to zero. I have attached capture4 to show what heppens then (this alows you to see what the fan ID is for each of the programs.
RE: Lost CPU Fan Spped Sensor Reading

Indeed, this is very strange. Seems both tools have problems reading fan speeds there.
When I verified the DBG dump you posted, I have seen invalid values for the first two fans (read straight from the fan control device).
It's also hard for me to believe that an earlier version of HWiNFO reported those fans, because this rather seems to be a system problem.
Do you have the older version of HWiNFO stored, so you could verify this again? If not, I can upload older versions, just tell me which ones.
RE: Lost CPU Fan Spped Sensor Reading

I am not sure my last composed message was actually posted - so I will do it again.

I reseructed an old save of HWIFO64 and ran it again. Attached are the dbg file and a screen shot showing it working correctly as I described.

The attachments do not seem to be getting sent. This is another try.

I see the capture file but not the dbg file. Looking in the directory I see it is 4+ megabytes in size - probably too large. I will rerun the old version of HWINFO64 and send a hopefully smaller file.

OK - this dbg file is much smaller. The screen output sill shows all 4 fans.


  • Capture5.JPG
    66.1 KB · Views: 13
  • HWiNFO64.DBG
    374.5 KB · Views: 5
RE: Lost CPU Fan Spped Sensor Reading

Thanks for the new data. It's really strange, because I haven't changed anything in that area between those versions.
Please try to disable the "Evaluate ACPI Methods" option in the latest HWiNFO version if that will make any difference.
RE: Lost CPU Fan Spped Sensor Reading

That seems to make no difference.

One thing I have not mentioned is that the line showing the Exhaust Fan comes and goes (on restarting). Running after disabling "Evaluate ACPI Methods" the Big Exhaust Fan line is gone. I do not think it is directly related to this disable though - I have seen it present and not present during our dialogue. I can find no rime or reason for its appearance/disappearance.

Note that up until my switch from 4.17 to 4.24 every fan showed up and tracked what SpeedFan reported without fail. In fact I am running speed fan now and it shows all 4 fans properly.

Another interesting thing I just noticed. I just ran prime95 to confirm that SpeedFan matched WHINFO - and guess what? The Exhaust Fan line magically appeared. When I killed Prime95 HWINFO64 hung and stopped working (I will include a screen shot).


  • Capture6.JPG
    204.4 KB · Views: 2
RE: Lost CPU Fan Spped Sensor Reading

Well, I have to admit that this is a total mystery to me :(
Are you maybe running any other hardware monitoring tool (except SpeedFan) in parallel? If yes, can you try to disable the others ?
RE: Lost CPU Fan Spped Sensor Reading

Hi Martin:

I suggest that it is a thread timing or synchronizing problem. (I don't wish to step on your toes but I have had many years experience as an embedded SW engineer and have seen things like this before).

What leads me to this idea is:

(1) You have not changed anything in that sensor area between the two versions of HWINFO.
(2) Depending on what sequence I do things the fan readings actually change. What I mean by that is if I cold boot (i.e. no Speedfan, no HWIFO driver installed) I end up with a sensor display that does NOT have the "Exhaust Fan" line. If I then run prime95 the "Exhaust Fan" line suddenly appears. Take a look at the attached 2 screen capture images - one before running prim95 and one after. Nothing else changed between the two screen captures - but the results are sure different.

I should also mention that while my rig CAN be overclocked - I have it set to use the AMD Q&Q. So my rig nominally runs at a 5X multiplier (probably while running the HWINFO setup). It will clock up 10X, 15X and finally 20X (while running Prime95 for sure). This would influence any thread timing. A possible cause?


  • Capture10.JPG
    22.2 KB · Views: 3
  • Capture11.JPG
    29.5 KB · Views: 4
RE: Lost CPU Fan Spped Sensor Reading

Thanks for your suggestions, however reading a register from the sensor monitoring chip (IT8720) doesn't require any such techniques that might have influence. It still doesn't explain why reading other registers (temperatures, voltages, other fans) works, when the access method for all registers is the same.
Maybe we might try to find the first version of HWiNFO that failed here. With v4.17 it worked and v4.24 doesn't. Can you please check versions between those to find the first guilty one ? If you don't have those versions, I can upload them and send you links.
RE: Lost CPU Fan Spped Sensor Reading

HI Martin:

I was not suggesting that it was the reading of the registers that was a problem. Only that between the reading and the display there might be a synchronizing problem. The dbg showed that the registers were read correctly - how about where they get displayed? A timing issue there could result if they were read after they were displayed and not before?

I would be glad to try other versions. I only have 4.17 and 4.24. Please send links to other versions and I will try them and find out where it fails.
RE: Lost CPU Fan Spped Sensor Reading

No, the debug data show, that the registers read out contain invalid data (0xFF) for first two fans. So the straight read-out of those values doesn't work.

I just found one more thing by comparing the 2 dumps you posted. It seems that in the one created using the latest version, the monitoring chip additionally reports that the tach count for Fan1 and Fan2 has exceeded the count limit. That means the chip is not able to measure current fan speed and explains why I read an invalid count value. So my conclusion is that HWiNFO correctly reads the values. There must be another difference...

Here are the other versions:
RE: Lost CPU Fan Spped Sensor Reading

OK - I ran all the versions you sent me.

First of all I apologize. I did not realize that the dbg file showed that the sensors were reporting an invalid value - that rules out a timing problem.

In all cases (17, 18, 20, 22 and 24) my rig seems to be "funny". In all cases I do not get the CPU nor Exhaust fan lines displayed until I run Prime95. In all cases speedfan and HWINFO agree with the displayed fan speeds. However, the CPU fan is displayed only on 17 and 18 - not on 20, 22 & 24. For sure the fan speed is displayed in speedfan properly for 20- but not on HWINFO.

So - I seam to have to budge the CPU to get HWINFO to display the fan readings - but speedfan does not require it.
RE: Lost CPU Fan Spped Sensor Reading

Thanks for the test results.
Just one more idea - please look at the end of the sensors list, if you maybe (at least sometimes) can locate the CPU fan speed there.