Missing some SYS_FAN_PUMP Sensors


New Member

I've loved just about everything about this app, except one thing - I'm missing a couple sensors (SYS_FAN8_PUMP being the most noticeable since it's connected to my pump (cable length and all). I can see FAN5 and FAN6 pump sensors, but for the life of me I don't see 7 or 8 (they show up in the BIOS).

It's a Gigabyte Aorus Master X570S if that helps. Thanks!
Those should be reported under a dedicated sensor called GIGABYTE EC. If you don't see this and have this sensor monitoring enabled and EC Support enabled as well, please attach the HWiNFO Debug FIle and I will check in detail why it's not showing up.
It's definitely picking up the other sensors (rad fans on CPU with correct RPM, a couple of EC_TEMP_1/2 sensors that I have attached to the coolant, etc). I looked and tried with both enabled and disabled a couple times just to be sure :)

Thanks for the assist!


  • HWiNFO64.zip
    123.4 KB · Views: 3
@Martin Apologies for the wait - I completely missed the forum notification. In any event I updated HWiNFO today and can verify it is now reporting FAN7_PUMP and FAN8_PUMP. Thanks again for running this down!

I do notice that the reported RPM hasn't changed in an hour of uptime - that could be true, but it seems a bit odd. Should I add another debug file?
That seems like some issue, does the initial RPM shown match the expected speed? Please attach the HWiNFO Debug File, I need to check the details.
I checked in the BIOS and it was doing the same thing - maybe a bad connection or pinout. I swapped to FAN6 and it works just fine. Darn Gigabyte :) All is well now, thanks again!
Happy New Year :)

Hi Martin,

thinking, that the same issue is on Gigabyte Aorus Master X670E. SYS_FAN7_PUMP and SYS_FAN8_PUMP are not showing up. Since I configure my Fans in BIOS, all fine there. The nearby CPU_FAN (to 8) and SYS_FAN6_PUMP (to 7) are shown correctly in HWINFO.


I appreciate it if you may take a look.



  • HWiNFO64.7z
    198.5 KB · Views: 2
HWiNFO has support for those fans via a special dedicated sensor but it looks like something in the system blocks access to this device.
Try to enable the "Low-level PCI Access" option in HWiNFO if that will maybe help.
Last edited:
Thanks Martin.

I'm sorry, unfortunately nothing changed so far. I searched the hidden values as well - didn't find the lost sensors. I also unchecked the 0x0 to 0xF SMBus Device Exclusions and reset whole Program. After that, I took the the Beta (v7.35 - 4950), but still no change - Everytime in mind to check Low-Level-PCI Access. Still as before.


Tested with 32-Bit (Beta) - no change.

Just want to prove that a Fan is installed ...

Last edited:
I'm wondering whether Virtualization / HVCI (Core isolation) or Secure Boot might be the reason for blocking access to this device.
You might try to disable all those features to see if that will help.
I appreciate your efforts. Thank you!

Both turned off stepwise and still no effect. :(
Maybe its related or not: After a while HWINFO is running, the Chipset (xHCI) Temperature is showing up. Sometimes already at Start, sometimes about an hour later. Just now its not showing, I will make a screenshot, when its back.
Please attach a new Debug File with all those features disabled and"Low-level PCI Access".

And here the mentioned Sensor, which is showing up sometimes:



  • HWiNFO64.7z
    259.9 KB · Views: 1
Last edited:
Thanks. There's an alternate method how to access the device responsible for the remaining fans, but it's a bit complicated to implement this and will require some effort.
Please run this build: www.hwinfo.com/beta/hwi64_735_4952.zip
and create a new Debug File using it. This build is just to give me more information how to implement support, so it won't work yet.
Hi Martin,

attached the corresponding 4952-Debug File. Thank you.


  • HWiNFO64-4952.7z
    259.5 KB · Views: 3
Thank you, I'm working on this but it's a more complex task...
BTW, have you maybe ever used the RW-Everything tool? It might be helpful if you could create some memory dumps using it from the FF010000 and FC010000 regions.
I haven't, but I downloaded it. Something to take care of ?

Assuming you would like to have this (as a binary?) - what length you're preferring from both of the adress regions?