Missing VS2013 CRT Dll's

jsmorley

Member
stangowner said:
Thanks Jeff.  We appreciate your support !

Nick,

HWiNFO is by far the best sensor monitoring tool available, certainly the best and most robust one that is supported via plugin by Rainmeter. I only regret we can't easily get it into our release "build", so it doesn't require any extra steps to be available to our users. Having said that though, it is still the most popular tool for this kind of monitoring in our community. I personally use it every day, and so do many of our users.

You can expect a bunch of downloads of the app and plugin when Rainmeter 3.3 hits...

Jeff
 

jsmorley

Member
Nick, 

I'd like at some point to better document the "remote" capabilities of the plugin, but I'm having some trouble getting it to work for me.

What I have is another computer, which is hard-wired to the router. I have installed the latest beta of HWiNFO on it and have it running. I have "Shared memory support" enabled, and under "Sensors", I checked the box "Server role" under the little "network" icon. I also did "Enumerate network", and it sees the computers / devices on my LAN.

Then on MY computer, which is connected to the router via WIFI, I am running the latest beta of HWiNFO as well, have "Shared memory support" enabled. When I do "Enumerate network" on this machine, I get no results.  In the Shared Memory Viewer, no "remote" computers are available.

Is there an issue with WIFI in this scenario? Or am I perhaps missing a step somewhere?

Jeff

Windows 10 Pro Insider Preview 64-bit (build 11082)
 

Martin

HWiNFO Author
Staff member
Jeff,
this is an "issue" of HWiNFO, not the plugin. You will need to connect from YOUR machine to remote one(s). I'm not sure why "Enumerate network" doesn't work, it might be something with access rights or firewall. Try to manually insert the remote machine's IP address and then hit Connect. When you see it connected, it should also appear in the SHM.
 

jsmorley

Member
Martin said:
Jeff,
this is an "issue" of HWiNFO, not the plugin. You will need to connect from YOUR machine to remote one(s). I'm not sure why "Enumerate network" doesn't work, it might be something with access rights or firewall. Try to manually insert the remote machine's IP address and then hit Connect. When you see it connected, it should also appear in the SHM.


Well, that worked fine. Thanks Martin. I'm not sure why "Enumerate" won't work, and still doesn't, but hard coding the desired IP address in there and hitting "Connect" worked just fine.

I wonder if on a network with DHCP providing IP addresses, it might be possible in the future to use the machine "name" rather than an IP address that may well be different after a reboot.

Anyway, this is probably the wrong thread for this discussion... ;-)

Thanks,

Jeff
 

Martin

HWiNFO Author
Staff member
Using the name instead of IP is one of the features I have been already checking. It might be available in the future.
 

stangowner

Moderator
I agree having some documentation on this would be helpful.  I'll write up a tutorial this weekend.  I did not find one when searching earlier this week.  However, it was intuitive and the enumeration worked for me so it was a 2 minute chore to get it working.  I'll be sure to include the IP trick in the tutorial.

BTW - all 3 of the PCs I used were DHCP, and one was on wifi.  They all enumerated and connected fine.  There was a quirk or two, but nothing to impact the functionality.
 

jsmorley

Member
stangowner said:
I agree having some documentation on this would be helpful.  I'll write up a tutorial this weekend.  I did not find one when searching earlier this week.  However, it was intuitive and the enumeration worked for me so it was a 2 minute chore to get it working.  I'll be sure to include the IP trick in the tutorial.

BTW - all 3 of the PCs I used were DHCP, and one was on wifi.  They all enumerated and connected fine.  There was a quirk or two, but nothing to impact the functionality.

I posted a link in my post on our forums to this:

http://www.ghacks.net/2015/07/15/hwinfo32-and-hwinfo64-5-0-ship-with-remote-sensor-monitoring/

It was a reasonably good description / images of setting it up.
 
Top