RAM Temperatures disappeared.


Since a few versions of the program, I have noticed that I no longer see the temperatures of my RAM modules. Before, I could see them, but not anymore. I've been waiting to see if it was something that was solved with some update, but I still do not see them.

Attachment file debug. I have not made changes in my BIOS, nor have I changed any piece of hardware since I could see the temperatures.

My motherboard is a MIS Z170A Gaming M7 and my RAM modules are GSKILL DDR4 3200 CL-14.

Thank you very much and congratulations for this great app.

Debug File:
It seems that something is blocking SMBus on your machine. If you run HWiNFO in normal (not Sensor-only) mode and you don't see memory module information, then it proves this case.
I see you have the "Synaptics SMBus Driver" installed and I know some versions of this driver were causing such issues. Is there any reason for using this driver? It's commonly used on notebooks for controlling the touchpad, but I guess your desktop machine doesn't have such a device.
Thanks for your quick response.

I just got home from work and I've looked at what you're saying. I do not know exactly why I have the "Synaptics SMBus Driver" installed, but it is. Could it have been installed by the IRTrack? https://www.naturalpoint.com/trackir/

I have unistalled the driver and after restarting, it is reinstalled automatically, so that it seems that there is a device that needs it.

I have also tried to disable it, but after rebooting and checking that it is still disabled, the problem persists.

Starting the program in normal mode, I see in the RAM section, which indicates that "Module Temperature Sensor (TSOD) is not supported." I guess it indicates this because as you comment, something blocks access to the sensor.
It is very curious, since before it worked perfectly.

Thank you very much for your attention.

P.D: In normal mode, I can see all the RAM information, except the temperature.
Can you please attach a new Debug File after starting HWiNFO in normal mode and then also opening sensors ?
All right. It seems that I have already found what is probably causing the malfunction, but I do not know why it is causing it or how to solve it.

I have installed the MSI Afterburner plus RivaTunner v7.1.0.15278.

I have closed it, and I have deleted the "HWINFO64.ini".

I have run HWINFO in "Sensors Only" mode, and the first thing I noticed was that the initial detection of the sensors was much faster, and the second thing is that the RAM temperatures were perfectly displayed.

Without closing HWINFO, I ran MSI Afterburner + Riva Tunner again and everything worked fine.

Now the mystery comes ...

I have removed from the Windows Automatic Start; Afterburner + Rivatunner, and I have restarted. When I ran HWINFO, I noticed that the sensor detection lasted a long time again, and when the program started, the RAM temperatures have not been seen again. I have restarted several times, I tried to erase "HWINFO64.ini" again, but the temperatures have disappeared and they have not come back.

P.D: I`ll attach a new DGB file in a minute.
So when HWiNFO doesn't show RAM temperatures, can you close it, start Afterburner and then start HWiNFO again?
Fresh Windows restart without Afterburner+RVTN.

New debug file in "Normal Mode +Sensors".


P.D.: Closed HWINFO, started Afterburner, and started HWINFO again. No mem temps plus long time detectecting sensors on starup.


  • dbg.rar
    84.5 KB · Views: 12
Well, that's strange.. You said you can see memory module details, but according to the new DBG file they are not detected.
So I'm wondering when have you see detailed memory information and also if you have found a reliable condition how to make the appear including the DIMM temperatures.
Sorry, but I meant different memory module information - either under the main Memory node, or in the summary under Memory Module (the empty box on the right side).
I see (sorry). The fact is that following the steps I have discussed, I managed to show the temperature and now despite playing the same conditions don`t see temps again.
Very frustrating.
Try to perhaps uninstall Afterburner, reboot machine, then install it again and run HWiNFO.
I have uninstalled Afterburner, Rivatuner and HWINFO.
I have downloaded the latest versions and reinstalled as indicated, but the problem remains the same.
I begin to believe that the problem is not in Afterburner, because I tried it with Afterburner + Rivatuner completely uninstalled. I think it must be something else.
Thanks for your efforts. If you think of something else ...
Sorry, I have no idea :(
Perhaps try to detach the device that's using the "Synaptics SMBus Driver" if possible.
I'll try. Let's see if I find out which device is using the driver.

Anything I find out, I'll let you know here.

Thank you very much again.
I have uninstalled the "Synaptics SMBus Driver" and deleted the driver. Then I downloaded the chipset driver from the manufacturer's page and reinstalled it. After restarting the system, I see that "Synaptics SMBus Driver" does not appear again, but the problem persists.

I attached a new DEBUG of "Normal Start + Sensors" without Afterburner being executed. If you are so kind, take a look to see if you see something new with the reinstallation of chipset.

Debug File 3:
I can see that default Intel driver for SMBus is used now, but SMBus still seems to be locked/blocked somehow and HWiNFO cannot see DIMM SPD nor the memory sensors.
Can you try some other tool like CPU-Z for example if that can see detailed memory SPD information?
Damn it, I just started CPUZ and it freezes when I start when it's in the SPD detection phase. This did not happen to me before.

I send you a detailed report of AIDA64 by PM. The program, in the SPD section, shows nothing.

Thank you for your patience.
Hello again. !I'm back! XD

Finally with certainty, I know who is blocking the SMBus. After many tests, the culprit was MSI Gaming App.

It has been to unistall it (it is not worth only to close it, it is necessary to unistall), and the readings of the temperatures of the RAM have not returned to fail nor once. In addition, the start / reading of HWINFO sensors returns to normal. Now it is much faster. Before, it could take half a minute.

I hope it can help if someone has the same problem.

What I find curious is that HWINFO in the normal start mode, in the memos section, tells me that the TSOD (Module Temperature Sensor) is not supported as you can see in the screenshots that I attached.

Thank you so much for everything. Greetings.