Support of RTSS - Displaying HWiNFO sensor values in Games

mike320

New Member
I had some trouble with beta RTSS, unrelated to HWiNFO. So basically, my question is if it's possible to get the extra data from RTSS into HWiNFO when RTSS's benchmark mode is on (min, max, low 1%, low 0.1%) Afterburner seems to be able to get those, so I was hoping HWiNFO could too, but I'm not sure of the technical details.

Is getting this internal gpu fps more efficient than getting it from RTSS?
 

Martin

HWiNFO Author
Staff member
OK, I think I got it now :D I checked latest RTSS and there are indeed some new items related to low 1% and 0.1%. I will add reporting of those values into the next HWiNFO build.
 

mike320

New Member
Perfect, thanks. Can you test it also with RTSS 7.2.3? It should report those values too if the benchmark mode is enabled.

Lastly, those values are meaningful if you are able to start the benchmark mode while in-game. Afterburner seems to be able to do this with a hotkey. If HWiNFO could also start RTSS's benchmark mode with a hotkey that would be great. RTSS 7.3.0 has some hotkey functionality itself but it seems that compatibility with some games might not be as good as 7.2.3
 

masterwishx

New Member
Hi, im using some values of hwinfo in Afterburner by his plugin ,how i can enable double numbers to see in afterburner ?
im only getting interger numbers of Watts for example from my PSU Power ...
in hwinfo itself its OK ,its in double. in MSI afterbuner its having range 0.0 to 1000.0 but still show only integer like "100" not "100.0" also tryed in cell "format " to write 0.0 still nothing.
 

p2im0

Member
EDIT: Paid for a pro license, ticked the "Shared Memory Support" box and all is working again.

@Martin, apologies for being one of these people - I promise I read the post, but it wasn't clear to me that lack of "shared memory support" was the issue.


Hi folks,
I noticed that with the launch of HWINFO v7.00 and later the RTSS OverlayEditor.dll functionality is now broken and RTSS is no longer able to pull any data from HWINFO. However, it's clear that HWINFO is able to output to RTSS when using the "OSD (RTSS)" tab in HWINFO to display individual values to RTSS.

For now I've rolled back to HWINFO 6.42 which still supports the custom overlay. See screenshots below.

HWINFO v6.42 and earlier - the custom OverlayEditor renders all HWINFO data items correctly:

Screenshot 2021-03-16 162740.png

Views of the OverlayEditor Data Sources, HWINFO data sources are all populated correctly with HWINFO v6.42 and earlier:
Screenshot 2021-03-16 163104.pngScreenshot 2021-03-16 163116.png




HWINFO v7.00 and later - the custom OverlayEditor for RTSS is unable to pull data from HWINFO:

Screenshot 2021-03-16 162756.png

Views of the OverlayEditor Data Sources, HWINFO data sources are all N/A with HWINFO v7.00 and later
Screenshot 2021-03-16 161835.pngScreenshot 2021-03-16 161851.png
 

Attachments

  • Screenshot 2021-03-16 161918.png
    Screenshot 2021-03-16 161918.png
    16.5 KB · Views: 11
Last edited:

Martin

HWiNFO Author
Staff member
 

p2im0

Member
Thank you for the clarification. I guess I misunderstood this specific statement in that article “RTSS support built-in HWiNFO will not be affected.”

but now I understand that relates to the RTSS tab in the settings. Appreciate all the support. I will be buying a license to support development :)
 

DSD27

Member
Not necessary, read the above posts.
I did, but I don't really get it, or I wouldn't have asked. The solution is to roll back to version 6.42, but will it be fixed in the next update? When I used up the 12 hours of shared memory, Riva Tuner kept not working.
 
Last edited:

p2im0

Member
I did, but I don't really get it, or I wouldn't have asked. The solution is to roll back to version 6.42, but will it be fixed in the next update? When I used up the 12 hours of shared memory, Riva Tuner kept not working.
Short version is:

  • if you've built a custom overlay that pulls data in RTSS from HWinfo, that is using the "shared memory support feature" and yes, you're stuck on 6.42 or must pay for 7.0+
  • If you want to display HWinfo values in RTSS you still can by using the HWinfo settings and enabling displaying of individual values, but you don't have precise control like you do with OverlayEditor.
I've been using HWinfo for years and don't mind supporting development and I love having my custom overlay so I bought a license.
 

DSD27

Member
Short version is:

  • if you've built a custom overlay that pulls data in RTSS from HWinfo, that is using the "shared memory support feature" and yes, you're stuck on 6.42 or must pay for 7.0+
  • If you want to display HWinfo values in RTSS you still can by using the HWinfo settings and enabling displaying of individual values, but you don't have precise control like you do with OverlayEditor.
I've been using HWinfo for years and don't mind supporting development and I love having my custom overlay so I bought a license.
But where is that "displaying of individual values" setting? I can't find it, I've rolled back to 6.42 and RTSS overlay is still not appearing in-game.
 

p2im0

Member
But where is that "displaying of individual values" setting? I can't find it, I've rolled back to 6.42 and RTSS overlay is still not appearing in-game.
Open HWinfo sensors panel, gear in bottom right of the main UI - then check off the sensors you want to display in the OSD (RTSS) tab, & tick "Show value in OSD". Still works in 7.0++


Screenshot 2021-04-02 181448.png
 

DSD27

Member
Open HWinfo sensors panel, gear in bottom right of the main UI - then check off the sensors you want to display in the OSD (RTSS) tab, & tick "Show value in OSD". Still works in 7.0++


View attachment 6226
That's how I've been doing it for years. But since I updated to version 7 and also updated RivaTuner on the same day, it never worked again. Maybe they've changed something too...
 
Last edited:

p2im0

Member
That's how I've been doing it for years. But since I updated to version 7 and also updated RivaTuner on the same day, it never worked again. Maybe they've changed something too...
Not sure what to tell you, I'm running RTSS 7.3.1 and HWiNFO 7.00-4400 and it's working for me. I didn't have to do any extra configuring, RTSS running, and check the box... double check hotkeys?

Screenshot 2021-04-02 235423.pngScreenshot 2021-04-02 235428.png

Display in Escape from Tarkov... I have OverlayEditor plugin off.
Screenshot 2021-04-02 235401.png
 

DSD27

Member
In the "position" I've set one to be on line 2. Does that count as "custom overlay"
 
Last edited:

Pinkie Pie

Active Member
I wish i had frametime showing as well in hwinfo64 now i have 6900 xt i no longer need msi afterburner, as can do fan control in amd own control panel, i still wanna show my framerate however as example via rainmeter on my 2e screen, just not sure how i am gonna do that when i go back to one screen in juni when i get my ultrawide
 
Top