Timestamp not current or missing form Digital Signature on HWiNFO64

Downloaded and install HWiNFO64 couple of days ago. And today I ran a digicert checkup using DigiCerUtil on the HWiNFO64.exe and the signature is good but the timestamp is not current or missing. Is this okay?
I don't see any issue with the timestamp. You can verify this by right-click on the HWiNFO64.EXE - Properties - Digital Signatures.
Yes weird on the Digital Signature Details Info screen it says
Name: DigiCert Timestamp 2021
E-mail: Not available
Signing time: Monday, October 4, 2021 1:40:36

Anyone else have the same? Just making sure I got the right file and not a different one
You have the right file. Really not sure what DigiCerUtil doesn't like here, but you'd get a warning from Windows if there would be a problem with the Digital Signature.
Weird when I run DigiCert Certificate Utility for Windows it says

(Green Check) The file is signed and the signature was verified.

(Yellow Exclamation Mark Sign) The signature does not contain a timestamp. It is strongly recommended that a timestamp be added to this signature.
I think the DigiCerUtil is buggy as it doesn't even recognize timestamps on Microsoft's own signatures. Just test explorer.exe in c:\windows