Widgets Not Showing On All Screens on Windows 10

megamorphg

New Member
Currently I am on the latest version of HWiNFO64 v7.16. This started occurring after updating to this version. (It did not occur previous to this version.) I am also on the latest version of Windows 10.

The main app is set to have "Show windows from this app on all desktops" enabled and this works fine.
1642289928862.png

But the widgets do not carry the same setting:
1642289869259.png

Even after enabling this it doesn't stick and the option remains disabled.

Previously, the widgets had the same setting as the main app.
 

Martin

HWiNFO Author
Staff member
I haven't been able to figure out yet why is this. You'll need to set "Show this window on all desktops" for each graph window individually.
 

megamorphg

New Member
I haven't been able to figure out yet why is this. You'll need to set "Show this window on all desktops" for each graph window individually.
I tried that and it doesn't work as shown in my screenshots: after selecting "Show this window on all desktops" it remains unchecked. This doesn't happen with any other app.
 

Martin

HWiNFO Author
Staff member
Strange, for me the "Show this window on all desktops" works for the sensor and graph windows too.
 

megamorphg

New Member
I also updated RTSS and MSI (both of which also have "Show this window on all desktops" enabled) and noticed this issue after.
But yeah, tried re-installing 7.16 and toggling the checkbox on/off and still see the issue.
 
Top