Will CORSAIR LINK 4.2.4.25. work with beta build 5.33?

Acp11

Member
Hi Martin,

I just noticed that corsair added Interlocking with third party application with their new CL4 release....does that mean I can now run HWinfo and CL4 together with no conflict between both software? and if so will the new beta release v5.33, Build 2922 solve this now if I install?

Thanks
 

Martin

HWiNFO Author
Staff member
Yes, the latest HWiNFO Beta adds the same interlocking mechanism as the new CL4 release, so they should work well in parallel now.
 

Acp11

Member
Thats great news! hopefully now I could use the OSD to monitor my hx850i & h110i gt without freezing CL4.
 

Acp11

Member
just installed and my hx850i and H110i gt work perfectly on the OSD..Finally!....when will the official release happen so I can actually install in the OS since the beta will not let me auto start the program.

Thanks
 

Martin

HWiNFO Author
Staff member
The Beta build supports all functions same as the final release.
You can also just copy the files from Beta over previously installed final release.
 

Acp11

Member
Martin said:
The Beta build supports all functions same as the final release.
You can also just copy the files from Beta over previously installed final release.
ok and how do I do that? just move the 2 files over in the final release folder on my c drive? i believe its just the hwinfo.exe and the INI file
 

Martin

HWiNFO Author
Staff member
Yes. You don't need to move the INI file in case you want to preserve some of your main (portable) settings.
 

Martin

HWiNFO Author
Staff member
We have just determined that the current Corsair Link software (v4.2.4.25) doesn't properly implement their own specification to synchronize with other applications.
This can sometimes cause issues when running other applications in parallel with CL, though the probability is much smaller than before.
On our side everything is correct, so you might better wait for the next update from Corsair.
 

Davidinlv82

Active Member
One thing I figured out with corsair link and the older versions was to just not have corsair link ever start when windows does, HWInfo will show everything including the fan speed but the only thing I have to do to make sure the fan kicks on and shows in in HWInfo was to restart CLink4Service in the task manager and then everything works perfect. You have to have corsair link installed and set up but not run when windows starts otherwise the conflicts occur and HWInfo doesn't show the fan speed working
 
Top