Can't see Fan control icon in HWinfo on my AW15 Laptop

Martin

HWiNFO Author
Staff member
I think that happens because the GPU is disabled by NVIDIA Optimus (not used). I'll try to fix the crashing.
 

biatche

Member
Martin said:
I think that happens because the GPU is disabled by NVIDIA Optimus (not used). I'll try to fix the crashing.
If you look at my screenshot, the GPU is enabled because i purposely ran a game in background.
I had tried to right click occt.exe (run with graphics processor: nvidia) too..

Even has a temperature of 50c.
 

Martin

HWiNFO Author
Staff member
I see, it seems my assumption was wrong. I'm checking it right now... Does it crash for you too sometimes as zach9054 ?
When it says the value is disabled, are you able to choose a Temperature 1 source from the drop-down list ?
 

zach9054

Member
Martin said:
I see, it seems my assumption was wrong. I'm checking it right now... Does it crash for you too sometimes as zach9054 ?
When it says the value is disabled, are you able to choose a Temperature 1 source from the drop-down list ?
Not if i pick gpu. When compal is enabled, it always says cpu under and shows the fan. sometimes gpu shows up too. Biatche's picture doesn't have gpu showing up in sensors.

Biatche, if you're reading this, try opening up your nvidia GeForce expirence program and then exiting out. See if the brings gpu up in sensors like in my pic. If not restart Hwinfo
 

Attachments

zach9054

Member
zach9054 said:
Martin said:
I see, it seems my assumption was wrong. I'm checking it right now... Does it crash for you too sometimes as zach9054 ?
When it says the value is disabled, are you able to choose a Temperature 1 source from the drop-down list ?
Not if i pick gpu. When compal is enabled, it always says cpu under and shows the fan. sometimes gpu shows up too. Biatche's picture doesn't have gpu showing up in sensors.

Biatche, if you're reading this, try opening up your nvidia GeForce expirence program and then exiting out. See if the brings gpu up in sensors like in my pic. If not restart Hwinfo
Martin, to better answer your question, heres a pic
 

Attachments

Martin

HWiNFO Author
Staff member
It seems that the issue is indeed because the GPU is disabled.
Looking at your screenshots, the GPU[#1] sensor in the main sensors window is either empty, or lists values as 0. That means the GPU is disabled (by Optimus) and in this state HWiNFO cannot access the GPU. If it would access it, the GPU would wake-up (due to HWiNFO reading its state) and then go to sleep, which would repeat per each refresh cycle in HWiNFO.
So HWiNFO claims that the sensor is disabled, because it cannot find any valid temperature values for it.
You can also try to keep the GeForce Experience open - that should keep the NVIDIA GPU enabled.
Another option (if you really want to use the GPU temperature as source for fan control) would be to enable the "Poll Sleeping GPUs" option in HWiNFO. This will however keep the GPU enabled while HWiNFO is active, thus consume more power.
 

Martin

HWiNFO Author
Staff member
biatche said:
Pity I don't have GeForce experience installed. I never install it.
More precisely it's not a feature of GeForce Experience, but the NVIDIA driver. So there's no need to install GeForce Experience, but opening the NVIDIA Control Panel should be sufficient on most systems to get the GPU to wake up.
 

Martin

HWiNFO Author
Staff member
biatche said:
"Technologically" speaking, how would you make this work correctly around 'Optimus' problem?
That depends on what's your preference - if you prefer lowest power (and thus having the GPU disabled by Optimus to preserve power), then you *might try* to set the GPU temperature as the source, but you will have to make this selection which the GPU is active, otherwise HWiNFO won't be able to select the source.
Theoretically this might work assuming that when the GPU is switched off, it will never reach a temperature threshold required to active the custom fan speed. This is because in the disabled state, HWiNFO won't be able to read its true temperature.
Other way would be to set the "Poll Sleeping GPUs" option as described above, which will however result in higher power consumption of your system.
 

biatche

Member
OK I can now select the GPU, and the source. so Custom Auto works..... although not completely correct

So anyway now...

I need to get the GPU running (to do this, i use occt and run graphics stress test) before clicking on sensors. then everything from here works wonderfully. but once the gpu is turned off (no longer in use)... the fan continues spinning (it should be turned off)

and as you would expect, the behavior is not 100% correct when it's turned on and off and on and off. First the temperature source disappears (it contiinues spinning at the current rate).

lets say 40c @ 2500 rpm, and 50c @3000 rpm. once optimus/nvidia isnt running anymore and i reopen hwinfo/sensors it no longer 'reacts' to "custom auto". im sure you expect this. so if it was previously at 2500 rpm, it will no longer spin at 3000 rpm once it hits 50c.

So if there's some sort of way hwinfo can record down / memorize which sensor it should be inquiring the problem should be solved. perhaps setup a variable for the user to tick lets say "dynamic sensor" (one that goes on /off). by ticking it hwinfo will record down the hardware address of the sensor and so not forget what sensor it is when it's disabled.

Anyway, wonderful work so far.
 

Martin

HWiNFO Author
Staff member
I'm not sure if I understand exactly your proposal, but I'm afraid the issue is that when the NVIDIA GPU is disabled, it's impossible to know the GPU temperature without waking the GPU up. In that state HWiNFO cannot perform fan control because it doesn't receive valid temperature values from the GPU.
Enabling the "Poll Sleeping GPUs" option will cause HWiNFO to wake the GPU in each cycle to read the values (I think this is also the mode used by some other tools like MSI Afterburner).
 

biatche

Member
What im trying to say is that... make it not forget the temperature source because it "disappears" from the list when its inactive. Make it -sticky- for such (optimus) devices. Since it doesn't know the GPU temperature, could it be made in a way such that when its inactive RPM should be 0.... or otherwise specified

if (gpu_sensor_present) use_custom_auto
else
set_manual=x (0 or 1000rpm)
 

Martin

HWiNFO Author
Staff member
That might be not as easy as it sounds ;)
Do you need to change the fan control table so often, that it's not possible to do this only when the GPU is active ?
 

biatche

Member
I don't have to change the fan control table often or at all

Problem is that, it's not behaving the way it should
ill test more to confirm but heres what happens if i recall correctly

hwinfo_sensors_open -> trigger_gpu_sensor(occt) -> hwinfo_fan3_customauto = as normal
reboot_pc hwinfo_sensors_open -> hwinfo_fan3_customauto = sensor_not_exist -> trigger_gpu_sensor(occt) = fan3_spin_at_last_state // probably 0rpm, need to test to confirm

if it's too hard i guess manual speed fixed at 2000 rpm is most appropriate, it does drain battery but better than this crappy alienware getting ridiculously warm
 

biatche

Member
so what I said above may not be 100% accurate. it does seem to 'save' and 'remember' the temp source so long as i dont go press save again.

but it continues spinning even when gpu is off.... but by setting 40c (seems like the idle temperature) to 0rpm..... it may be a workaround. i'm not sure.

does setting rpm to 0 cause problems instead of telling the fan to turn off? in fact, how does the motherboard tell a fan to be zero? by disabling or setting rpm to 0? im not nearly satisfied setting it to 0 rpm, feels weird but if it works appropriately i think its good enough.
 
Top