Fan Control

N5110

Member
I don't know the ODM of my notebook. How do I find it out?
But I know the EC type. Its one of the nuvoton NPCE795x family.
The best solution would be to modify the fan speed look-up-table in the EC ROM. Do you have any experience in doing so?
 

Martin

HWiNFO Author
Staff member
Hard to say how to find that out, maybe disassemble the notebook and look for labels, or check internet for any clues.
The EC model doesn't matter much, because its firmware is important and that depends on particular implementation.
There might be a look-up-table or might be not - depends on implementation. In either case modifying such values often requires the disassembly of the firmware and performing modifications there. This is a very complex and dangerous job (making a mistake could render your machine unusable and might require a JTAG reflash), so I'm not intending to be involved in such modifications.
Sorry, but such things go far boyond the scope of HWiNFO and I'm not intending to support all possible notebook models nor perform any modifications to the EC.
 

N5110

Member
Thank you very much for your help. You are right it isn't worth modifying the EC firmware since it is really complex and risky.
So I have to live with the low/high fan speed settings. Anyhow the HWiNFO fan contolling is better than the native one.
Thank you!
 

db75

New Member
Hi Martin and many thanks to your unique software :)

For me it's working well (dell vostro 3560) except one thing.

Even it set auto run and auto read sensors, the custom fan control isn't working.
I must click on the fan icon (only that) to get my fan settings applied.

Do you know something about that ?
 

Martin

HWiNFO Author
Staff member
Please put at the end of the HWiNFO32.INI (or HWiNFO64.INI respectively) the following entry: "OpenFanCtrlMin=1" (it must be in the [Settings] section). That will automatically launch the fan control window and make it active.
 

ogrozion

Member
Dear Martin,
The fan1 is not showed in sensor list at HWiNFO Sensor Status when running on battery. To enable it I have to click on FAN icon. Running HWiNFO64 v4.30 on HP Elitebook 2540p with SMSC EMC2113.
Thanks in advance,
oGrOZion
 

Martin

HWiNFO Author
Staff member
Please use the latest HWiNFO version and post here the HWiNFO Debug File with sensor data for analysis.
 

ogrozion

Member
Martin said:
Please use the latest HWiNFO version and post here the HWiNFO Debug File with sensor data for analysis.
ok! Updated to latest, 4.36
Debug snapshot taken using AC power chord, battery charging.
I'll take another running on battery.
Thanks in advance,
oGrOZion
[hr]
Howdy, here comes HWiNFO64-battery, depicting battery powered computer.
Note that FAN is not appearing in SensorStatus. FAN icon is showed at botton.
cheers..
 

Attachments

Martin

HWiNFO Author
Staff member
Ah yes.. When running on battery it seems that the fan is either OFF, or the fan control logic is not properly configured by the BIOS, so the reported fan speed is 'out of range'.
When you open fan control, HWiNFO corrects this ;)
 

ogrozion

Member
I this snapshot, I've clicket at FAN icon and set manual mode to start fan. Battery powers the computer.
Thanks in advance
oZ
[hr]
I've formatted the computer and install W7 and HWiNFO, everything worked before this ocasion. I don't remember what HWiNFO version I was using, probably 3.6 or something like that. The BIOS was flashed too. Is there a way to "automaticaly click" on FAN icon to enable it?
Thanks in advance.
oZ
 

Attachments

Martin

HWiNFO Author
Staff member
If you want to automatically start fan control in HWiNFO, add the following line at the end of HWiNFO64.INI file:
OpenFanCtrlMin=1
This might be used together with other autostart options in HWiNFO to achieve automatic start with fan control in minimized mode ;)
 

ogrozion

Member
Martin said:
If you want to automatically start fan control in HWiNFO, add the following line at the end of HWiNFO64.INI file:
OpenFanCtrlMin=1
This might be used together with other autostart options in HWiNFO to achieve automatic start with fan control in minimized mode ;)
I've used this option to start HWiNFO, is there a option to force fan..?. HWiNFO starts but FAN not. In fact, OpenFanCtrlMin=1, was disabled because HWiNFO freezed on autostart with debug enabled.
Should I enable UEFI at BIOS?:rolleyes:
 

Martin

HWiNFO Author
Staff member
Fan should automatically start with that option. You don't need to use Debug Mode in normal runs, only if you want to send me the DBG file.
 

ogrozion

Member
Martin said:
Fan should automatically start with that option. You don't need to use Debug Mode in normal runs, only if you want to send me the DBG file.
Unfortunately does not start... it only starts when AC power is on... Is there a way (gadget, HWiNFO64.ini...) to call/enable FAN? (like click in icon, manual mode and adjust speed)
 

Martin

HWiNFO Author
Staff member
So when running on battery, the fan does start only if you manually open the Fan Control and doesn't when you have that OpenFanCtrlMin option enabled?
 

ogrozion

Member
Martin said:
So when running on battery, the fan does start only if you manually open the Fan Control and doesn't when you have that OpenFanCtrlMin option enabled?
Precisely... OpenFanCtrlMin option is enabled, fan only runs if I manually open the Fan Control.
[hr]
Should I try to flash an older BIOS version and use a legacy HWiNFO? I've found a 3.7 (seemed different than that used before format..) ... no fan at all... Could you point me to 3.9 or early 4x versions?
 

Martin

HWiNFO Author
Staff member
Do you have to perform any actions in the Fan Control window, or does the fan start immediately when you open the window?
Sorry, I was wrong about the OpenFanCtrlMin - in your case, you should not need to use that. The fans should automatically set the desired mode when you open the sensors window (or configure HWiNFO to open sensors automatically minimized).

No need to use different BIOS or HWiNFO versions.
 

ogrozion

Member
Application runs (autostart), I detect that fan is not running, open Sensor Status, look at SMSC EM2113, detect that Fan1 is not present (line clear, no RPM..). Click on botton icon (which opens Fan Control), enable manual mode, change the Manual Fan speed slider from 0 (it returns to zero...) to around 75%, click on Set Speed. The fan returns to work acording to value set on slider.
 

Martin

HWiNFO Author
Staff member
Ah, now I know :) The manual fan speed setting is not saved by HWiNFO for next runs. You will need to modify the LUT table with your custom values. This will then be restored when you run HWiNFO and open sensors (no need to perform any more actions in the fan control).
 

ogrozion

Member
I've modified. When the temperature reaches any level, PWM stays at minimum value... could be changed only manually.
 
Top