HWiNFO64 crashes before opening

Swifty

Member
Note: Maiden append. Be kind to me, I'm a pensioner! I worked in IT since the IBM S/370 was announced; 37 years of that with IBM, some in PC H/W and Software support. I retired from IBM in 2012 in happy circumstances.

On my system, HWiNFO64.exe crashes as soon as it is launched (Windows description: "Stopped working", optimistic since it never started...). It has done this for every version I've tried (including betas)

HWiNFO32 tells me:
 
 Motherboard: ASUS P8Z77-V LX
 Processor:     Intel Core i7-3770
 Memory:       16Gb

… more details on request.

If there's anything I can do to identify the source of this problem, just let me know.
 

Swifty

Member
My apologies; I hadn't realised that I could get to the debug setting before the abend. Here is my DBG file.

Last two lines: (to give you a taster)
- Analyzing PCI Bus...
CL init
 

Attachments

Swifty

Member
Incidentally, I'd like to explain that I'm not usually so poor at collecting diagnostic information.

But I'd just installed a USB3 disk enclosure, and it seemed to require updates to my USB3 drivers. Every time I tried to update the USB3 drivers, I ended up with damaged USB2 drivers. The USB2 driver problem disabled my keyboard/mouse (amongst other things), and Windows Power Saving took out my displays after 5 minutes of "inactivity". The recovery was easy (I logged on using Remote Desktop Connection from my HP Proliant server) but I still got incredibly stressed.

Then, my last driver update not only disabled USB2, but left it disabled after rolling out the USB3 update. And after using System Restore to before my application of the USB3 update!

Anyway, HWiNFO32 was brilliant in diagnosing the USB problems. I just wish it hadn't told me than my OCZ-VERTEX4 128Gb C: drive has zero Drive Remaining Life...
 

Martin

HWiNFO Author
Staff member
The crash is caused by an OpenCL sequence HWiNFO performs to wake potentially sleeping GPUs.
This might be resolved by upgrading the graphics drivers.
If that doesn't help, disabling the "Wake disabled GPUs" option in HWiNFO.

If you get that working and want me to check the problem with remaining drive life, please attach another Debug File (without crash) and I'll check that.
 

Swifty

Member
Disabling "Wake disabled GPUs" fixed the problem. Thank you.

I'll leave the graphics drivers alone. After three days battling with USB drivers, I've thrown in the towel on drivers.

I've attached the Debug file to see why my OCZ-Vertex4 drive says zero Drive Remaining Life. The system was assembled September 2012, so it's quite young. I use my PC a lot, but I avoid overloading the C: drive, if only because it has only 128Gb and I'm running low on space.

The only unusual thing about my C: drive is that it contains a few Junction points to other drives in my system. I don't see how that could affect lifetime, though.
 

Swifty

Member
I forgot to attach the debug file the first time around, so I edited the post, and attached it from there.  I had a feeling that it didn't "take".

Once more for luck... third time lucky?[attachment=1213]
 

Attachments

Swifty

Member
Gmail has an add-on which scans for the word "attach" or "attachment" and complains if you haven't added an attachment.  I desperately need this function in all of the programs that I use. I always remember after pressing "send", like I did with this. in response to my prior post. :(
 

Martin

HWiNFO Author
Staff member
Thanks for the file. I'm sorry, but I forgot to ask for additional information - either a screenshot from the main window / drive showing the S.M.A.R.T. information, or the HWiNFO Report File.
 

Swifty

Member
I'm trying to attach the report file, but something is preventing me. I'm not getting any error messages, so I don't know what I'm doing wrong.

Ah, it doesn't like the extension .MHT so I've renamed it to SWIFTYS.MHT.DBG
 

Attachments

Martin

HWiNFO Author
Staff member
Thanks. This is strange, but it really seems that the drive reports 0% remaining life.
Can you please try another tool for confirming (from OCZ, or CrystalDiskInfo) how much remaining life it reports ?
 

Swifty

Member
CrystalDiskInfo also reports Remaining Life: 0

Perhaps I have more to worry about than USB drivers... I was looking for an excuse to upgrade from 128Gb to something larger...
 

Martin

HWiNFO Author
Staff member
Just to be sure - I think there should be a tool from OCZ. Best would be to confirm it using that tool.
 

Swifty

Member
That's a good plan, thanks.

I downloaded the OCZ Toolbox, and it agrees with HWiNFO and CrystalDiskInfo.

I used the toolbox to send a "Trim" command to the drive, but that made no difference.  

I could try a microcode update, but given my zero success rating with recent driver updates, I think I'll avoid this.

My current plan is to buy a 240Gb SSD to replace my existing 128Gb OCZ Vertex4, swap it in, then recover my C: drive from a Macrium Reflect image, using their standalone bootable CD.

Wish me luck...
 

dobermann

Member
Hi! i'm have same problet at this morning. HWInfo crashes when i try view my sensors (by clicking "Sensors" button). This occurs during scanning computers, because I have time to see one warning window (alert). Please take a look my DBG file.
 

Attachments

Martin

HWiNFO Author
Staff member
Is that alert you see something you have configured before ?
Please try to do a "Reset preferences" in HWiNFO main settings to see if that will help.
 

dobermann

Member
Martin said:
Is that alert you see something you have configured before ?
Please try to do a "Reset preferences" in HWiNFO main settings to see if that will help.
I configured HWinfo for connecting to my 30 computers in the LAN.  Until this day everything worked perfectly.
I try "Reset preferences", but this not help. Application still crashes when i press "Sensors" button..
 

Martin

HWiNFO Author
Staff member
Can you please attach a new Debug File after you have done the Reset Preferences ?
 
Top