Support for M2 SSD Crucial P2


I have Crucial P2 M2 SSD, but unfortunately HWinfo only see the NVMe Controller.

It would be nice to have it supported as a drive too so i could monitor it's temp.

Thanks you.


  • PC.HTM
    231.3 KB · Views: 1
  • CrystalDiskInfo_20220117211259.png
    54.2 KB · Views: 5
This is most probably because Windows 7 doesn't support NVMe pass-through functions, which are available since Windows 10.
Alternatively you might try to install some NVMe driver (e.g. Samsung) which supports this functionality.
Then why it work with with CDI and Crucial Storage Executive ? and it's not a fake temp.

I already installed the Crucial NVMe driver, can't install a Samsung one with a Crucial drive, at least the one i tried.
It seems to support dedicated NVMe functions for this controller on Win7.
Can you please go into CDI menu Function - Advanced Feature - USB/IEE1394 - and disable all SCSI_NVME_TRANSLATION items (JMicron, ASMedia, Realtek) ? Then restart CDI and check if the Crucial drive is found. If not, try to enable them one by one until it's found. Please let me know which of those items needs to be enabled so that it's found.
I don't think it will help much, CDI still see the SSD even with everything disabled there.


  • cdi.png
    65.1 KB · Views: 4
Interesting.. Please open the DiskInfo.ini file of CDI and set DebugMode=1. Then restart it and after closing please attach the DiskInfo64.log file it created.
There, i hope it will help you.

Edit : renamed the file with .txt, as .log was not allowed.


  • DiskInfo64.txt
    7.9 KB · Views: 1

The new french translation is funny !

It's detected now, but it look like it can't get any info from it.

I joined both report and debug files just in case.


  • HWi.png
    84.8 KB · Views: 5
    199.3 KB · Views: 1
  • HWiNFO64.DBG.7z
    55.1 KB · Views: 0

It's not that bad, but it must be an automatic translation so some text are funny ( especially the "present" functionality that literally translate as "gift" ).

And now it work just fine !

Thanks you very much.