Alienware X51 R2 fan control

I had the fan speed control working until I updated to hw64_450. I tried to go back to the version I had before but can't get it working, maybe I no longer have the right version? I believe it was hw64_44?. Not sure and only have hw64_442 and hw64_448 My computer runs too hot to not have your program installed and running correctly. :huh:  On idle runs 125* to 140* up to 189* under some loads!
Thank you very much for your work! :)

Alienware X51 R2, 16 GB duel channel, Intel Core-4770--[7RPX5N], Nvidia GeForce GTX 760 TI 2G GDDR5, Win 7 Home Premium 64 bit.
 

Martin

HWiNFO Author
Staff member
You haven't specified what's not working there, but there were no changes to Alienware fan control in HWiNFO in recent versions.
I suggest you check your settings, especially for the fan lookup table if the temperature sources are properly configured.
 
Oh I've added OpenFanCtrlMin=1 to ini list. and fan control still doesn't show in sensors. I tried a lot of your suggestions from various threads and no show for fan control. Only one version seemed to work because I updated before and had to go back to the previous version before. But I forget which one that was?
 

Martin

HWiNFO Author
Staff member
That option should have no effect. Do you have "EC Support" enabled in HWiNFO ?
Please attach the HWiNFO Debug File for analysis.
 
[attachment=1286][attachment=1286][attachment=1286][attachment=1286][attachment=1286][attachment=1286]
Martin said:
That option should have no effect. Do you have "EC Support" enabled in HWiNFO ?
Please attach the HWiNFO Debug File for analysis.
Ok I had to cut the report short because it was 4 .3 megs. here it is shortened
 

Martin

HWiNFO Author
Staff member
Please check in HWiNFO settings that you have the "SW SMI" option enabled.
If you have, then please attach a new Debug File from the latest HWiNFO version. If the file is too large, pack it (ZIP) before attaching.
 
Martin said:
Please check in HWiNFO settings that you have the "SW SMI" option enabled.
If you have, then please attach a new Debug File from the latest HWiNFO version. If the file is too large, pack it (ZIP) before attaching.
Thank you. :)  "SW SMI" is enabled. Thanks for advice on file. :blush: [attachment=1288]
 

Attachments

Martin

HWiNFO Author
Staff member
Please get the latest version of HWiNFO and then disable the "EC Support" option.
Let me know if that helped.
 
Top