Freeze, immediate shutdown or BSOD caused by HWiNFO

Pauls

Member
Hello,

I can't confirm that for 100% but when I have HWiNFO always running in the tray, as the startup app my machine shutdowns or freezes immediately in a second every few days/week.
How do I know it? When I disabled HWiNFO and it's not running anymore those problems don't occur anymore.

My machine is a Lenovo Thinkpad P15.

Threads I've created on the Lenovo community:
- https://forums.lenovo.com/topic/findpost/1306/5076409/5311588
- https://forums.lenovo.com/topic/findpost/1306/5081341/5339061

Do you know the app may behave like that?
Any solutions?
Maybe the driver that's loaded by HWiNFO is unstable or anything?

Thanks!
P
 

Pauls

Member
Yes, the latest one.
Do you think it will dumb anything if my machine shuts down in 1ms without a warning or anything in the event viewer?
 

Martin

HWiNFO Author
Staff member
It will write what HWiNFO is doing to the disk, so if you grab the DBG file after shut down I can analyze what was the last operation that might have caused the issue.
 

Pauls

Member
One more question: how to grab the DBG file without overwriting it when the app starts up along with the system every time?
 

Martin

HWiNFO Author
Staff member
If you have HWiNFO automatically started then you'll need to deactivate this to avoid overwriting the previous DBG file.
 

Martin

HWiNFO Author
Staff member
I see something, but not sure whether this is the reason of the crash.
Try to disable the "Evaluate ACPI Methods" option in HWiNFO settings if that will help.
 

Pauls

Member
Disabled that and awaiting results.
Let's see if my machine will have any issues in the next weeks.

Why "Evaluate ACPI Methods"?
What is it responsible for and how it may mess around?
 

Martin

HWiNFO Author
Staff member
The "Evaluate ACPI Methods" option doesn't seem to be disabled according to that Debug File. Are you sure it was?
 

Martin

HWiNFO Author
Staff member
Hmm, but you should not see the "ACPI: ..." sensor when that option is disabled, which isn't the case according to the last DBG file.
So I'm wondering whether that run was really made with "Evaluate ACPI Methods" disabled.
Anyway, try to also disable the "EC Support' option. That should now remove the "ThinkPad EC" sensor as well.
 

Pauls

Member
Ok :)

I will also stop and rerun the app after changing this setting.
Let's see how it will be in the incoming weeks.
 

Pauls

Member
We can't be sure for 100% but when there is no HWiNFO running the problem never occurs.

For how long. In terms of sleep and wake up very long. That's why the file is 19GB size.
 

Martin

HWiNFO Author
Staff member
I don't see anything in HWiNFO that could be triggering such issue anymore.
 

Pauls

Member
Thank you. Maybe this time it was something else because with the settings you suggested me in this thread this problem doesn't occur anymore periodically. It's possible this time it was some accident or other software.

Thank you
 
Top