Intermittent cooler pump speed detection

Dan_G

Member
I recently upgraded the air cooler on my server to a liquid cooler and now the pump speed is rarely detected by HWinfo64 on Windows 10 x64 1903 though UEFI always sees it and HWinfo64 always saw the air cooler. CPU is a 4790K, motherboard is a ASrock Z87 Extreme 6, air cooler was a Zalman CNPS8900 Quiet, and liquid cooler is a Cooler Master ML120L with PWM fan on Chassis 1 header and pump on three pin CPU header. Any ideas?
 

Attachments

Martin

HWiNFO Author
Staff member
This is because some older ASRock mainboards (including yours) used a very odd implementation for measuring fans on the CPU1/2 (or sometimes Chassis too) headers. They combined them together and if one wants to access them, he needs to constantly switch between. This is not supported by HWiNFO, as it would cause issues with other tools too.
Try to connect the pump to a different header and monitoring should work OK.
 

Dan_G

Member
Monitoring works now, but speed control doesn't. SMH. I'll have to try other headers later today. Hopefully one will control the pump and let me monitor it. Interestingly, I'm getting lower temps during this experiment, suggesting that the CPU fan headers are underpowered. Yet another wrinkle to work around.
 

Dan_G

Member
For future reference (not that many affected boards are around anymore, but why not). Four pin (PWM) headers will monitor three pin fans and power them at 100% but not control them. I don't know if both CPU fan headers can be used simultaneously so I haven't tried it. I was wrong about them being underpowered, as it seems I wasn't letting handbrake run long enough during my testing. I was able to get all the fans controlled and monitored that I was wanting to by switching headers.
 
Top